3
$\begingroup$

I am having somewhat of a problem. I get a real nice flame and smoke in the Viewport but when I render only the fire does. I've been to other forums and tried different things but can't figure out what it is.

This is a screenshot of the viewportThis is a screenshot of the viewport

And this is a screenshot of the render enter image description here

Here's the link to the blender file if it helps.

Thanks everyone.

$\endgroup$
  • 1
    $\begingroup$ The problem was quite simple - attribute name. In Cycles the spelling of attributes matters, including capital letters. And there isn't attribute "Smoke", you have to use "density" (w/o quotes) instead. With that corrected - i.imgur.com/N661GoK.png If you don't want these difficulties use Quick Smoke operator on desired mesh, see - blender.stackexchange.com/questions/45697/…. For smoke setup see blender.stackexchange.com/a/24424/1245. $\endgroup$ – Mr Zak May 13 '16 at 22:35
  • $\begingroup$ @MrZak This doesn't seem to fix my problem for some reason. I had actually tried that before. I tried it again and it still behaves the same. Any ideas why? $\endgroup$ – edherigh May 16 '16 at 18:04
  • 1
    $\begingroup$ Because you multiply density by 1, which means using default values; and by default density isn't visible that much. Also don't combine fire with smoke via Mix node, rather than with Add. You could try creating some dummy mesh and assinging Quick Fire+Smoke to quickly check how settings should look like. As a side note I suggest deleting caches, rebaking and replaying animation. $\endgroup$ – Mr Zak May 16 '16 at 21:43
2
$\begingroup$

Select the Flow object and make sure that the Flow Type: is set to Fire + Smoke. It is likely just set to Fire. If this doesn't help, consider uploading a .blend so someone can locate the problem more easily.

Edit:

Got it! The issue was in your nodes. I'm not quite sure what the issue was, but I replaced the current smoke nodes with this, which I plugged into the mix node that the other thing was previously plugged into:

enter image description here

The value in the multiply node affects how dense the smoke is. Here is the fixed .blend file:

$\endgroup$
  • $\begingroup$ Thanks for answering @ShadyPuck. I checked the flow type as you suggested and it is set to Fire + Smoke. I am attaching a link to the blender file under my original post. Thanks, again. $\endgroup$ – edherigh May 13 '16 at 19:04
  • $\begingroup$ @edherigh I found the problem and updated my answer. The .blend I included includes the solution. Glad to help. If you wouldn't mind accepting my answer (the checkmark near the top left), I would be grateful. $\endgroup$ – Shady Puck May 13 '16 at 21:16
  • 1
    $\begingroup$ @ShadyPuck The issue is that the original file is trying to use Smoke as attribute instead of density $\endgroup$ – user1853 May 14 '16 at 7:37
  • 1
    $\begingroup$ I believe it was the scatter node. I don't think that you had one originally. $\endgroup$ – Shady Puck May 16 '16 at 18:41
  • 1
    $\begingroup$ Smoke isn't combined with fire via Mix node, rather than with Add. Scatter node was present in the original setup. The problem was in the attribute property spelled wrong, but that just was not the only problem. The density was too small. $\endgroup$ – Mr Zak May 16 '16 at 21:41
0
$\begingroup$

If you are GPU rendering, ensure you are the on the latest version of Blender (2.77). Older versions do not allow for GPU rendering of smoke/fire/particles.

https://wiki.blender.org/index.php/Dev:Ref/Release_Notes/2.77/Cycles

$\endgroup$
  • 1
    $\begingroup$ if this were the problem, it would not render just fire, it would render nothing. $\endgroup$ – Shady Puck May 13 '16 at 11:33
  • $\begingroup$ @Kirbinator, thanks for answering. I am using blender v2.77. I rendered using the CPU just to be sure and I still get the same result. $\endgroup$ – edherigh May 13 '16 at 19:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.