6
$\begingroup$

When in pose mode, the bones on my model wont transform, they are stuck in rotate mode, though I can scale them. This problem now occurs whenever I try starting a new project. Some bones that I made earlier still work, but whenever I try to make new ones, they are stuck in rotate. It seems like I changed something in the settings, but I don't even know how to access the settings. Please help, thanks.

$\endgroup$
4
  • $\begingroup$ Have you reset your factory settings? File > Load factory settings. Then Ctrl+U to save it as the default file. $\endgroup$
    – CharlesL
    Dec 3, 2013 at 0:16
  • $\begingroup$ Yes, I have tried that, but it didn't help. Thanks anyways. $\endgroup$
    – Joshua
    Dec 9, 2013 at 23:21
  • $\begingroup$ Even When I change transform in the settings it doesn't work. $\endgroup$
    – Joshua
    Dec 9, 2013 at 23:46
  • $\begingroup$ Check if the auto IK is on,if its on turn it off and that will fix your problem $\endgroup$
    – user19858
    Dec 1, 2015 at 12:48

7 Answers 7

10
$\begingroup$

I found the solution! You have to click on the button shown in the photo below. sorry for my bad English I'm only 14 years old

enter image description here

$\endgroup$
3
  • 2
    $\begingroup$ Welcome to B.SE! This is actually the button for the "Manipulate center points" tool that Oliver mentions in his answer, but he only gives the hotkey. Additionally, you'll notice that the OP says they CAN rotate, which doesn't describe what happens when this is turned on. Good effort! Keep contributing! $\endgroup$
    – Matt
    Mar 26, 2014 at 16:21
  • $\begingroup$ Matt's right, it didn't work, but thanks for helping. $\endgroup$
    – Joshua
    May 15, 2014 at 22:49
  • $\begingroup$ I have the same problem! I know where the problem is, I can't solve it. !enter image description here At the picture, on the panel N, there is the option 'transform location' which is locked (I realy don't know why) and it is causing that when you grab the bone, it just rotates. $\endgroup$
    – user3512
    May 16, 2014 at 18:43
3
$\begingroup$

Try to check if the Rotation axes are locked occasionally.

enter image description here

$\endgroup$
14
  • $\begingroup$ Or, it's Location lock. Because in his case, the bones can rotate or scale, but not translate. $\endgroup$
    – Adhi
    Dec 3, 2013 at 2:26
  • $\begingroup$ @Adhi It would be better to see what's happening there. A demo file is needed. I don't think rotate works there, since OP said "Stuck in rotate". $\endgroup$ Dec 3, 2013 at 5:15
  • 1
    $\begingroup$ "Won't transform, stuck in rotate mode" as in, the bone can only be rotated, maybe? True, it could be read another way. Troubleshooting-questions without illustration are often the most tiring to answer. $\endgroup$
    – Adhi
    Dec 3, 2013 at 5:32
  • $\begingroup$ How do you fix location lock if it is that, and the rotate works but the transform will not. $\endgroup$
    – Joshua
    Dec 9, 2013 at 23:21
  • $\begingroup$ @Joshua Would you like to share a demo file with us? It will be quite nice to look into it by this way. $\endgroup$ Dec 10, 2013 at 1:44
2
$\begingroup$

I'm not sure if this will help at all, but I stumbled onto this question looking to solve the same (if not seemingly the same) problem in my own project.

Of course the answer to my problem turned out to be quite simple. While yours may not be so, I figure it's worth checking.

Have you cleared the parent from the bone you're trying to move?

$\endgroup$
3
  • 1
    $\begingroup$ The first part of your answer does not appear to help solve the question. Consider revising to make it more concise, and in future try posting suggestions like this as a comment first in future. $\endgroup$
    – J Sargent
    Dec 21, 2014 at 20:08
  • 3
    $\begingroup$ @NoviceInDisguise Note that users with less than 50 rep cannot comment on other posts. $\endgroup$
    – gandalf3
    Dec 21, 2014 at 20:39
  • $\begingroup$ Good point . . . $\endgroup$
    – J Sargent
    Dec 21, 2014 at 20:46
2
$\begingroup$

I recently had a similar problem which turned out to be caused by accidentally activating the option to "Manipulate center points" (shortcut Alt+,). This will (as a side-effect) disable rotation and scaling in pose and object modes. It's the symbol right next to the pivot mode with the three dots above a two-sided arrow.

$\endgroup$
1
  • $\begingroup$ I tried activating that option, and it disabled all movement unless it was from the starting/parent bone. Also, the rotation is working, but the transform doesn't. Thank-you. $\endgroup$
    – Joshua
    Dec 9, 2013 at 23:28
2
$\begingroup$

This sounds like bones in the hierarchy are parented with connected head/tip. There are two ways to parent a bone: 'connected' and 'with offset'. 'Connected' means the head of the child bone will snap to the tip of the parent and the two bones are joined at the junction. If you try to move one, the other will be adjusted as well. 'Offset' means the two bones are still in a hierarchy, but they are not joined at the head/tip junction. The child is free to move in its parent's space in all three transforms. This is signified by a dotted line between the head of the child and tip of the parent in edit mode.

If your bones are connected, you can break this connection without breaking the parent/child hierarchy with Alt+P and choosing 'disconnect bone'. To make a parent without the snapping, simply choose 'with offset' when you parent.

$\endgroup$
1
  • $\begingroup$ Hello, can someone tell me where the option is in the version 2.8 and above? $\endgroup$
    – Fowl
    Sep 21, 2020 at 9:03
1
$\begingroup$

It's possible that you've changed a setting somewhere, but (especially if you don't know how to get to those settings anyway) I think it's more likely that you need a little more information about how rigging normally works.

There are a number of reasons that your bones might not be moving the way you expect them to. The most likely is that you have a constraint that is limiting the way your bones can move.

One way this normally happens is if you're setting up an IK chain, then the bone at the end is the only one that will move. The bones in the middle have all been told to maintain the IK solution, which means you can't move them. This is normal.

Something similar can happen if you have other kinds of constraints set up. If you've used a constraint to tell a bone "Always point at this other object over here," then it will always point at that other object over there, even when you try to move it.

Also keep in mind that when you're creating a rig, the idea is that they are BONES like in your body, which means that they are always attached to each other (this is not always true, but is usually how characters are done). So if your forearm can't move (because you don't have it selected) and your shoulder can't move (because you don't have it selected) then if you try to move your upper arm, it's not going to go anywhere; it's locked in place because it's not allowed to influence the two other bones it's attached to. Of course, this isn't how your body works, but keep in mind that the computer is dumb. It can only make assumptions that it's been TOLD to make, and it's usually safer not to make any assumptions, so it doesn't make a bone move until you tell it exactly how to move it, either by selecting it, or by giving it rules like with a constraint.

Although I'm using anatomical illustrations, the principles apply to any other kind of rig in which your bones are attached to each other in a hierarchy.

Good luck!

$\endgroup$
1
  • 1
    $\begingroup$ You are right, I am still very inexperienced with rigging, but I have not been able to find this on video tutorials. I haven't set up any constraints yet, and I don't think that I am setting up an IK chain. Thank-you $\endgroup$
    – Joshua
    Dec 9, 2013 at 23:35
0
$\begingroup$

Today I found out that the "Auto-IK" option on Armatures can interact catastrophically with existing IK constraint chains. If the tip of your IK is locked to a position and the transforms aren't locked and there are no other constraints at play, try turning off Auto-IK. Where the Auto IK option is located in 3.0

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .