1
$\begingroup$

I cannot import an .svg file into Blender. I have tried other files and they work. I have checked the User Preferences and the "import SVG" option is enabled.

How can I tell if this one .svg file is formatted correctly for Blender?

Any help is much appreciated.

Thanks.

$\endgroup$
  • $\begingroup$ possible duplicate of: blender.stackexchange.com/questions/23170/… $\endgroup$ – cegaton May 11 '16 at 12:53
  • $\begingroup$ What was the SVG created in? Did you make it, or was it downloaded from somewhere? Do other SVG files import fine? Also, if you run Blender from the terminal, add-ons will often report errors there. So if you run Blender from the terminal and try to import this SVG, do you see any errors? $\endgroup$ – Fweeb May 11 '16 at 12:56
  • $\begingroup$ Other related links: blender.stackexchange.com/questions/44520/… and blender.stackexchange.com/questions/8016/… $\endgroup$ – cegaton May 11 '16 at 12:57
  • 1
    $\begingroup$ As long as your SVG file contains paths (vectors) the color for them should be imported. $\endgroup$ – cegaton May 11 '16 at 13:35
  • 1
    $\begingroup$ @jawinn if you use inkscape you can load the jpeg file and trace it there see this link $\endgroup$ – cegaton May 11 '16 at 14:13
1
$\begingroup$

I'll bet that you have a rasterized image that's been embedded in an SVG file.

When Blender imports an SVG, it takes the spline curves that define the vector graphic in the file, and convert them to splines (or a mesh) to define it in 3D. Unfortunately, you can have a rasterized (pixel-based, instead of vector-based) image embedded in an SVG project. That image will not be imported by Blender because it doesn't have any splines or vectors.

You can check this by opening the file in an SVG editor (like Inkscape or Illustrator) and trying to select the vectors that define the borders. If you can't select any edges, then zoom in super close and see if you start seeing pixels. If you start seeing pixels, then it's rasterized, not vectorized.

If that's actually the case, then this IS a duplicate of Why can't I import a SVG file from Adobe Illustrator or Inkscape?

I hope that helps!

$\endgroup$
  • $\begingroup$ I was able to load the image into Inkscape. I don't see any pixels. The image is huge though. It is 5 megs. When I get it loaded into Inkscape, it covers the Inkscape canvas. Imagine a pillow covering a postage stamp. My image is the pillow. $\endgroup$ – jawinn May 11 '16 at 17:48
  • $\begingroup$ More info. My image used a combination of vector and rasterized elements. I am guessing this is my issue. Would I have to have the image redone into 100% vector to make everything work? Thoughts? $\endgroup$ – jawinn May 11 '16 at 18:52
  • $\begingroup$ Yes, anything that you want to import will have to be vectorized. Look into Trace Bitmap. Inkscape can do that, and Illustrator can, too. You could also just trace it in Blender ;-) $\endgroup$ – Matt May 11 '16 at 18:54
1
$\begingroup$

To import an SVG file go to File > Import > Scalable Vector Graphics(SVG)

enter image description here

Make sure that the SVG file you are importing contains vectors (paths) Blender cannot import raster data or text directly form SVG files. In other words, the information on the SVG has to be traced. For a detailed explanation read this link

If the plugin is not enabled for any reason go to the User Preferences Window (press CtrlAltU and enable it there.

It is also possible that your file is importing successfully but is so small that is hard to see on the viewport. Check if the outliner shows one or more curve objects. enter image description here

If so, select one of the curves and press Numpad . to move the view to selected. Then you should be able to see the object.

$\endgroup$
  • $\begingroup$ I see more than one curve. However, I only see a tiny dot in the middle of the main editor. I tried selecting the dot and scaling the image, but the dot just moves around. $\endgroup$ – jawinn May 11 '16 at 17:43
  • $\begingroup$ Select the curve on the oultliner with a right click and choose select. Then on the 3D viewport press numpad . (period) to have the veiwport zoomed on your object. $\endgroup$ – cegaton May 11 '16 at 17:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.