0
$\begingroup$

I'm trying to apply the UV grid textures to my character,but for an unknown reason,it did not work as expected. When I go in Object mode and then I change the texture viewport shading to Textures,the look of the skin don't change. It should look like a grid chess,but,instead are the eyes to change look,infact they seem to be darker. Where is the error ? thanks.

1 2 3

While,it worked in a earlier version (the white,blue,black are the colors of the eyes) :

enter image description here

enter image description here

$\endgroup$
2
$\begingroup$

In the first screenshot, it seems that the penguin has no material, unlike in the last screenshot where the penguin has 3 materials assigned (and there it shows the texture)..?

enter image description here

Could it be just this?

Edit: Following you request in comments/chat, I did a test:

1.I downloaded your file, saved on my desktop

  1. I created a new default file in blender

  2. I appended just the penguin mesh from your file (I found it's named "untitled" in your file, under "mesh" folder.

  3. Then I selected my default cube object, and switched to the "object data" in its properties panel

  4. From the "browse mesh data to be linked" selection tool, I selected the previously imported penguin mesh, named "untitled".

  5. Now my "cube" object has a penguin shape. Your UV grid also gets imported.

  6. Setting viewport shading to "textured" shows the textured penguin!

enter image description here

So, I think the object in your file was corrupted, but the mesh is fine.

You can correct your file in this way, I think.

Btw, your mesh has arms normals inverted, select all mesh vertices, and fix them (CTRLN).

This is my file:

Hth.

$\endgroup$
  • $\begingroup$ Is this a question or an answer? $\endgroup$ – cegaton May 10 '16 at 14:51
  • $\begingroup$ I attached the blender file. Check it out. And check the last picture : you will see the colors of the eyes,but not the color of the skin.... $\endgroup$ – Marietto May 10 '16 at 15:01
  • $\begingroup$ @cegaton could it be a questionable answer?,In my native language, this is a way of answering... it's a way to express my feeling that the error could be a really basic one... iif it's not not acceptable, I could edit and transform the "question" into an affirmative phrase... $\endgroup$ – m.ardito May 10 '16 at 15:02
  • $\begingroup$ also check the latest attached picture...I added a material,but it does not work anyway... $\endgroup$ – Marietto May 10 '16 at 15:04
  • $\begingroup$ yes it is weird. I added a texture (missing) to the material, I added a cube and the grid texture shows just fine. tried to recalc normals (on arms are inverted). Did you import this model? $\endgroup$ – m.ardito May 10 '16 at 15:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.