7
$\begingroup$

I have 64GB of RAM on my computer and I'm trying to check if Blender is using all that it can.

I still get viewport slowdown at times when working with complex objects. I know there are many settings in the preferences and I want to know how I can tell if windows 7 and Blender are working to use all 64GB of RAM.

$\endgroup$
7
$\begingroup$

You can tell how much memory Blender is currently using by looking in the info bar: http://puu.sh/5A0U6.png

You can use that to see if Blender's memory usage is hitting a plateau, but it seems to me your issue is your graphics card. More memory won't make your viewport faster, that's what a graphics card will do. More memory means Blender doesn't have to swap as much data onto the hard drive. That means more memory makes:

  • Getting cache for simulations faster (this won't necessarily make it run faster, it'll just make the data easier to grab). Apparently it also is necessary to compute high resolution fluids (thanks gandal3)
  • Viewing undo history faster (again, this is just accessing the data, not computing it).
  • Speed up loading large images (because it won't have to swap to the hard drive every time you adjust the image)
  • Video editor/tracker cache will also be stored on memory if it is available (which is of course faster than storing it on the hard drive) (thanks again to gandalf3).
$\endgroup$
  • 1
    $\begingroup$ IIRC fluid simulation needs a certain amount of RAM for some reason to be able to compute high resolution fluids. Another thing that lots of RAM is useful for is video editing and tracking. $\endgroup$ – gandalf3 Dec 2 '13 at 19:37
4
$\begingroup$

You could increase the memory available for video sequence in the User Preferences / Interface Tab
I found that the settings limit is 32GB.

enter image description here

After that adding a few flics increase memory usage significantly in the task manager, (I couldn't see that when baking a fluid simulation).

enter image description here

When you notice a slow down in your viewport, it is highly unlikely to get any advantage from additional memory (once the mesh is loaded). To verify that you could monitor your cpus if they are fully utilized additional memory will have no effect.

$\endgroup$
  • $\begingroup$ AFAIK that setting only affects the VSE and the tracking editor. $\endgroup$ – gandalf3 Dec 2 '13 at 20:11
  • $\begingroup$ @gandalf3 Yes, I couldn't see any memory allocation although it was shown that baking should require 40GB, it seems that this is dumped straight to disk, I guess he tries to find the bottle neck. $\endgroup$ – stacker Dec 2 '13 at 20:15
  • $\begingroup$ I have NVIDA Titan. Should i get 2 or 4 Titan. Set up as SLI or QUAD? Or just put in 4 cards and blender will know what to do? $\endgroup$ – user1730 Dec 2 '13 at 21:41
  • $\begingroup$ @user1730 You should really check the benchmark results blenderartists.org/forum/… from what I know SLI or Crossfire is only helpful for games and doesn't speed up Cycles. $\endgroup$ – stacker Dec 2 '13 at 22:12
2
$\begingroup$

Its way too old, but may be use full for somebody else;

You may try to set the memory limits in blender settings as follows;

File -> User Preferences -> Editing

and set the memory limit to 0, Zero means no limits, blender may use full memory.

As shown below; Best of luck

enter image description here

$\endgroup$
  • $\begingroup$ This is only for Undo's and the number of Steps is capped at 256 anyway. $\endgroup$ – bertmoog Jul 28 '17 at 16:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.