when I import image as plane, in the setting panel for diffuse and emission, there are not other options. Many tutorials mention a diffuse & transparency option but I don't seem to have it. Blender 2.77

thanks Alister from NZ

  • 2
    $\begingroup$ Are you using cycles? If you use cycles, enable Use Alpha to get automatic nodes setup $\endgroup$
    – Denis
    May 10 '16 at 3:22
  • $\begingroup$ related, possible duplicate: blender.stackexchange.com/questions/57712/… $\endgroup$
    – user1853
    Jul 13 '16 at 4:11

These settings are render engine dependent, that means the options available depend on which rendering engine you are currently using, like Cycles or Blender Internal (Also called Blender Render).

On the info window you can change the render engine:

enter image description here

Transparency and emission options are material properties and the addon must be able to create a material with those properties for rendering system currently in use, so some options are only available for Blender Internal materials others for Cycles, since they use completely different and independent material definitions.

To see the options for each render engine read this post:

Long story short, decide which render engine you are going to use, then if the desired options aren't immediately available from the importer adjust you material manually afterwards.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.