3
$\begingroup$

I frequently run into a very annoying problem when rendering scenes with cycles where I use an environment texture. Upon rendering the animation, Blender sometimes looses the environment texture, displays it as pink and renders the whole frame unusable. The render then stops, I have to manually save, close, restart the program and continue rendering. It happens about 3-4 times in 300 frames during a 6 hour rendertime. It happens on both CPU and GPU renderers and happens on different computers, even different users (a friend of mine has the same problem). The problem occurs in Blender 2.76 and 2.77.

The GPU renderer outputs this error message: cuda error at cumoduleload: file not found I tried relocating the texture to a SSD, a different HDD, the projects directory, nothing helps.

Any ideas? Thanks for the help :)

$\endgroup$
2
  • $\begingroup$ Same Probleme. Not always but often when i use a .dds texture. $\endgroup$
    – user2488
    May 9, 2016 at 20:55
  • $\begingroup$ If this happens in different computers or under different users you may have encountered a bug in the software or have a corrupt file. Is this happening while rendering from the same file, or is your friend experiencing the same in a different .blend file or the same texture? If so this may be worth reporting to the bug tracker. $\endgroup$ May 10, 2016 at 1:46

1 Answer 1

1
$\begingroup$

I run into this issue all the time, mostly when using scenes that have DDS files as textures. No idea what the issue is, but I use a workaround to avoid it.

If you run it from the command line with a limited number of frames per run, you can do the whole run without worrying about getting the pink textures. For example, the following series of commands will render frames 640 through 669, in 3 batches of 10 frames each. By using the #### format in the render output, it will automatically put the frame number into the filename. That way you can get a nice image sequences without running into the texture issue.

blender --background intro_scene.blend --engine CYCLES --render-output //tmp/HM-####.png -s 640 -e 649 -a blender --background intro_scene.blend --engine CYCLES --render-output //tmp/HM-####.png -s 650 -e 659 -a blender --background intro_scene.blend --engine CYCLES --render-output //tmp/HM-####.png -s 660 -e 669 -a

No idea why it does this in the first place. It's really frustrating. Here's the full error for anyone who wants to dig into it a bit more:

Failed loading CUDA kernel C:\Program Files\Blender Foundation\Blender\2.79\scripts\addons\cycles\lib/filter_sm_52.cubin.
Error: CUDA error at cuModuleLoad: File not found
$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .