6
$\begingroup$

I had been working on a Blender file for about an hour when my whole system just crashed and powered itself off (using Ubuntu 13.10, and I had many applications open).

The /tmp directory where the autosave file is typically found had no blender files in it.

I just opened Blender again and confirmed that the autosave feature is working properly according to my settings (saving 2734.blend every 3 minutes).

So why is there no autosave file? The /tmp directory had other files in it, so I don't think that Ubuntu crashing caused the file to be deleted.

$\endgroup$
  • 1
    $\begingroup$ I have had the same problem when blender crashes running ubuntu 13.4 $\endgroup$ – Qwertie Dec 2 '13 at 7:59
  • 1
    $\begingroup$ Did you have to reboot the system? The /tmp directory is usually stored in RAM, which means that everything in it will be lost when the machine restarts. $\endgroup$ – gandalf3 Dec 2 '13 at 8:28
  • $\begingroup$ Yes, the system powered itself off during the crash. I edited my answer to reflect that. $\endgroup$ – Garrett Dec 3 '13 at 21:55
  • 1
    $\begingroup$ @Garry In that case the reason why the file is missing is because it was lost when the computer turned off. :/ $\endgroup$ – gandalf3 Dec 3 '13 at 21:59
4
$\begingroup$

It seems /tmp is cleared on startup in ubuntu by default, so unfortunately if you had to reboot your machine everything in /tmp was erased. The other files you saw in /tmp were probably created on startup.

Blender has some other backup systems (see this post), but if you did not make any manual saves I'm afraid there is nothing to be done.

Autosaving to the hard drive:

You could change the directory blender uses to store temporary backups to a location on your hard drive by changing the Temp location in CtrlAltU> User preferences > File:

User preferences screenshot

Note that this setting controls the location of everything blender puts in /tmp by default, not just the autosave files.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Great, thanks @gandalf3! Changing the Temp directory worked, which I confirmed forcing my computer to power off. But I don't believe that /tmp is held in RAM judging by this page. $\endgroup$ – Garrett Dec 3 '13 at 23:22
  • 1
    $\begingroup$ Also, building off the answer @gandalf3 gave above, an alternative (but not necessarily better) solution is to change the frequency with which /tmp is cleared by following Max's answer here. $\endgroup$ – Garrett Dec 3 '13 at 23:27
  • 1
    $\begingroup$ @Garry It can be, but it does seem that you are right that it is not in RAM by default on ubuntu. $\endgroup$ – gandalf3 Dec 3 '13 at 23:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.