1
$\begingroup$

I have a model that has all materials applied. I use Blender export feature, click 3DS Max, save the file, but if I import that same file back into Blender, it loses all the materials -> they're converted on a white colour. Materials are based on an image texture. The file also loses the UV. What am I doing wrong?

$\endgroup$
  • 1
    $\begingroup$ Where are you trying to export to, what other software will you be using this in? 3Ds file format doesn't support exporting materials, beyond basic properties like colors and UV coordinates, as far as I know. In fact most exchange formats have very limited or basic material support, since materials are a inherent and specific property of the rendering system and very much tied to the engine they were created with, as far as I understand. $\endgroup$ – Duarte Farrajota Ramos May 8 '16 at 17:19
  • $\begingroup$ I'm actually selling this one on Turbosquid, thought more formats I have, the better, but I found out that those exported formats don't work properly so I have to keep on only .blend file for now. So basically I'm trying to prepare as many formats as possible for using the model in any engine or software. $\endgroup$ – user3123 May 8 '16 at 18:40
  • 1
    $\begingroup$ Well provide as many formats as possible, but other that OBJ (which from the top of my head creates .mlt files with some basic material properties I think) most other formats are geometry oriented, and don't try to provide material output. And for a good reason too, materials, are too tied to the render engine and there is no "universal" way of exporting them. Anyway I wouldn't bother too much with it, it's pobably a waste of time. Provide the necessary textures (like diffuse, specular, bump, normal, etc.) and UV coordinates for them and should suffice. $\endgroup$ – Duarte Farrajota Ramos May 8 '16 at 23:49
  • $\begingroup$ Oh, so you suggest to sell that geometry by itself and add texture files on top of that? $\endgroup$ – user3123 May 9 '16 at 13:17
  • 1
    $\begingroup$ Yes, that is usually the way to go, from what I've seen. Provide the model in the basic standard formats like OBJ, 3Ds, FBX, Collada etc, and a bunch of reusable textures so people can leverage them as the see fit , like the standard diffuse + specular + bump + glossiness + normal + etc. or whichever ones you find relevant. Not all always are needed, the user will then use only the ones they need to create materials for the application they are using, it would be unfeasible to provide materials for all possible applications. $\endgroup$ – Duarte Farrajota Ramos May 9 '16 at 14:29
1
$\begingroup$

Additional regarding Fbx

3dsMax

  1. Make sure your units match that of Blender (meters for this example) - Customize menu - units setup.
  2. Import your Fbx file.
  3. Although your lights and camera import they are not compatable with 3dsmax rendering. You will need to discard your lights and camera and install most probably photometric lights and at least one of the system cameras in order to render. 2) - Your scale will be correct.

Maya

  1. Change working units in Maya to meters or match your settings from blender.
  2. Windows - Settings and Preferences - Preferences -- Click on Settings. Under working units change to meters or match blenders settings set before your project.
  3. Import your Fbx file.
  4. On importing you will have your lights and camera. However they are probably not compatable (untested as yet). You will probably have to set up new system of lights and cameras. 3) - Your scale will be correct.

Fbx Review

  1. Opens correctly in Fbx review.

Lightwave 2015

  1. Opens correctly in Lightwave 2015 Modeler. Scale is correct. No lights (modeler).
  2. Imports correctly in Lightwave 2015 Scene. Scale unverified. Option to play with scale on import. Cameras and Lights available but compatability unverified.

Other systems as yet untested


Exporting to Collada from Blender

Phases 1, 2, 3, and 4. as above

Phase 5 Export your model to .Dae

  1. Export to .Dae as below
  2. In the properties panel -(Render Tab) set animation frame rate to match your target systems default. check defaults or settings on other systems.
  3. Select File - external data - (check) Automatically pack data into .blend
  4. Save your .blend file
  5. Select File - Export - Collada
  6. Leave all Collada export settings at their defaults. Change only if you are deviating from this recipe for good reason.
  7. Export Collada
  8. Open the file in an application that supports Collada. Autodesk FBX review is an excellent one for checking (make sure textures are switched on)

Additional regarding Collada

3dsMax

  1. Make sure your units match that of Blender (meters for this example) - Customize menu - units setup
  2. Import your .dae file
  3. You will loose your lights and cameras. - Set up new lights and cameras.
  4. Your scale will be correct

Maya

  1. I don't have the version that supports .3ds import.

Fbx Review

  1. Opens correctly in Fbx review.

Lightwave 2015

  1. Opens in modeler. Geometry only. UV mapping unknown. Scale is correct. No lights (modeler).
  2. Imports into Lightwave 2015 Scene. Lights lost camera displaced and probably inoperative. Scale unverified. Option to play with scale on import. Texture (will turn some lights on to verify)

Other systems untested


Exporting to 3ds from Blender

  • The methods above do not work for Autodesk Fbx reviewer and 3dsMax but 'Load object' does work for lightwave 2015 modeler. However the scale of the import is 10 times too large. There is no where to adjust scale on the exporter and lightwave is fixed in meters. My thinking is that you must model in blender at 1 tenth scale to achieve the expected result for lightwave. Further cameras and lights are not imported as it is Lightwave modeler only. Further Lightwave's rendering package does not support .3ds.
  • in Autodesk FBX review - scale is lost - proper geometry is lost - textures are maintained. UV mapping appears correct but the object is warped.
  • In 3dsMax I have proper looking Geometry although there seems to be a few additional verticies somewhere. Scale is correct but textures are lost. If you look in the textures 'slots' in the materials editor the correct name of the texture is there but the swatch is black. This is someting to do with paths I think. If the texture can be located in the correct place then perhaps it could become available. You would still have to manualy map the texture adjacent to the diffuse colour tab in the materials editor. The uv mapping may still be intact (untested) as the result from Fbx reviewer would suggest that the uv mapping does make it through the export at least.
  • Regarding Maya I don't have the version that supports .3ds import so I could not test.

Additional

Lightwave 2015

  • Does open in a lightwave 2015 modeler. (File load object). Uncheck Scale Object in the import dialogue for correct scale.
  • Does open in a lightwave 2015 scene. (File load object). Uncheck Scale Object in the import dialogue for correct scale. Load object means system cameras and lights.

Other systems untested


Exporting to obj from Blender

As above for Phases 1, 2, 3, and 4. as at top

Phase 5 Export your model to .Obj

  1. Export to .Obj as below
  2. The obj file format does not support animations natively so don't waorry about frame rates.
  3. Select File - external data - (check) Automatically pack data into .blend
  4. Save your .blend file
  5. Select File - Export - wavefront (.obj)
  6. In export settings export set scale to 1 if you are going to 3dsMax and 100 if you are going to fbx review. Only deviate from defaults for good reason.
  7. Export OBJ
  8. Open the file in an application that supports OBJ. Such as Autodesk FBX review (make sure textures are switched on)

Additional regarding obj

3dsMax

  1. Make sure your units match that of Blender (meters for this example) - Customize menu - units setup
  2. Import your .obj file
  3. In the import dialogue of 3dsMax - Check - flipZY-axis.
  4. You will loose your lights and cameras. - Set up new lights and cameras.
  5. Your scale will be correct

Maya

  1. Change working units in Maya to meters or match your settings from blender.
  2. Windows - Settings and Preferences - Preferences -- Click on Settings. Under working units change to meters or match blenders settings set before your project.
  3. Import your Obj file
  4. You will not have any lights or camera. You will have to set up new lights and cameras.
  5. Your scale will be correct.

Fbx Review

  1. Opens correctly in Fbx review with the 100 x scale adjustment in the Blender Obj exporter settings.

lightwave 2015

  1. On 'open object' the following error message occurs - Can't find file "Images\myTexture.jpg" select an alternate file? Select Yes and locate your texture file manually.
  2. The scale will be correct. (The Lightwave grid can cause some confusion regarding scale)

Other systems untested for .obj thus far

$\endgroup$
  • $\begingroup$ Read the first answer at the top before you read the second answer. The second answers attempts to address exporting with textures. It is by no means exhaustive and doesn't address all the issues regarding texturing, materials and exporting. Answer two is merely a basis for some experimentation. $\endgroup$ – Gavin Kneale Jan 7 '18 at 12:53
  • $\begingroup$ Please have a look at the formatting changes I have made by clicking the 'edited x amount of time ago' link below your answer to see how to do formatting in future. The answer was quite unreadable, so please check that the section separations are correct. $\endgroup$ – Ray Mairlot Jan 7 '18 at 16:04
  • 2
    $\begingroup$ @GavinKneale instead of adding more answers you can use the edit link at the bottom of your post and make single a comprehensive answer. Also please pay attention to the formatting to make your text more readable. $\endgroup$ – cegaton Jan 7 '18 at 16:14
-1
$\begingroup$

This is intended for newbies like myself and anyone who wants to export from Blender to Fbx with basic textures. It may or may not be usefull when exporting other formats. I apologise it is verbose and intended for beginners.

Phase 0 1) - For export at least to FBX Set your renderer to Blender Renderer an not Cycles Renderer. 2) - Set your units of your scene. 3) - Fbx defaults to meters. On the Scene tab on the properties panel find units and change length to metric. Change units to meters also for good measure.

Note: ( When you are complete and you have opened your Fbx up in another application such as Maya or 3dsMax the import dialogue will state that your file units are cm. This seems to be an abberation of sorts. This is also of no consequence as your imported Fbx will still be to scale. I suppose it comes in as 100cm instead of 1m. - Reason unknown)

Phase 1 Create your Model -1) - Create or Import your model into Blender. -2) - Clean up your model

Phase 2 Get a Material/texture assigned to your model -1) - Get a material in the material slot in the properties panel - (materials tab) -2) - Get your texture into a texture slot in the properties panel - (textures tab) -3) - Set - mapping - coordinates - to UV and mapping - projection to flat (textures tab at bottom) -4) - In edit mode with the relevant part/s of your model selected and from the materials tab assign your material to your selected part/s.

Phase 3 UV Map your model -1) - Click and drag an new viewport open from the top right hand coner of your screen. Split your screen 50:50 left and right. -2) - In your new viewport open the view port options menu and select UV/Image Editor. -3) - Return to and select your default 3d viewport. -4) - In edit mode (edges) - using shift select your intended seams for unwrapping. -5) - Cntrl E to bring up the Edges menu and select mark seams. -6) - Still in edit mode using the A key toggle to select all. -7) - Still in edit mode now using the U Key bring up the uv mapping menu. -8) - Select - unwrap. -9) - Arrange your UV Islands (pack UV islands ect.)(Indepth uv mapping separate subject) -10)- Switch to 'view materials' in the default 3d view port- (Precheck your model and textures)

Phase 4 Turn on some lights -1) - Add some more lights so that you can properly see whats going on in your scene. -2) - In object mode - Shift A - In your default 3d viewport. -3) - Select Lamp - Point Light. -4) - Drag the point light up in the Z direction from the origin 0,0,0. Drag X and Y directions to suit. -5) - Repeat the above steps at least once more so that you have at least three point lights in your scene lighting all sides of your model. -6) - These lights should be on when you create them if they are not figure out how to switch them on. -7) - Make sure you are still set to 'view materials' in your default 3d view port. -8) - Check your model -9) - If you have any dark or black faces then flip normals for the effected faces as below. -10)- In edit mode (faces) select the affected faces. -11)- From the adjacent Mesh menu select - Normals - Flip normals. -12)- Also try select - normals - recalculate - if you still having issues.

Phase 5 Export your model -1) - Export to Fbx as below -2) - In the properties panel -(Render Tab) set animation frame rate to match your target systems default. (30 for 3dsMax or Maya and perhaps others) -3) - Select File - external data - (check) Automatically pack data into .blend -4) - Save your .blend file -5) - Select File - Export - Fbx -6) - Leave all FBX export settings at their defaults.(FBX 7.4 Binary and all preset defaults). Change only if you are deviating from this flow for good reason. -7) - Export FBX -8) - Open the file in an application that supports Fbx. Your whole scene icluding lights and textures should be there.

Note - This basic setup could be the basis for some experimentation for Blender exports to other formats although different file formats address textures differently, both regarding texture file location and their implementation. Sticking to this basic recipe is probably not a bad idea especially if you are new to blender. - Thanks to the posters who have got me going with blender.

$\endgroup$
  • 1
    $\begingroup$ This is currently pretty unreadable. Please have a look at the formatting help and the formatting changes I made to your other answer. $\endgroup$ – Ray Mairlot Jan 7 '18 at 16:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy