I'm new to the Blender game engine and I don't know what to do with this model glitch. Certain parts of the model aren't showing and there is no shading. How do I fix this?

enter image description here

  • 1
    $\begingroup$ its hard to tell since we don't know how it's supposed to look, but try recalculating normals and changing the viewport from solid to textured $\endgroup$
    – tacofisher
    May 7, 2016 at 20:41
  • $\begingroup$ try chaining to textured shading. You are in solid. $\endgroup$ May 8, 2016 at 3:36
  • $\begingroup$ that did not work at all i guess this model is not fer the bge $\endgroup$
    – James
    May 9, 2016 at 21:55

1 Answer 1


For the shading problem: the viewport is currently in shaded mode enter image description here If the textures still aren't showing, bear in mind that only image textures are supported.

For parts of the model not showing, it is likely that the normals are inverted or that you are using single planes. In computer graphics, most faces have only one side, and if you look from the other side they will be transparent. To fix this you can: - Flip the normal to face the correct way (edit mode -> select face -> ctrl+N) - Disable backface culling

Viewing the normals using one of the following options is reccomended: enter image description here As should be evident, the selected faces have their normals flipped and are thus not visible from where the camera is.

  • $\begingroup$ Also from what I remember the BGE only likes a few image file formats for textures like jpeg and TGA i think $\endgroup$ Jun 14, 2016 at 11:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .