I want to change the pivot point of an object through quad view, but when I try to position it inside the object, the 3D cursor just jumps to the area/spot where I clicked on the face of the object. In short, How do I keep the 3D cursor from positioning itself right on the face.

  • $\begingroup$ It's very simple. Just zoom in where you want to position the 3d cursor. Select the area, then press Shift+S and select Cursor To Grid (This locks the cursor to the nearest grid point). Ensure, you are win wireframe mode. $\endgroup$
    – Ali Jibran
    Commented May 7, 2016 at 8:43
  • $\begingroup$ 3D Cursor will be put to the nearest surface point of the object if you just click with LMB. Do not use this method for precise positioning of cursor, use Shift+S menu instead. $\endgroup$
    – Mr Zak
    Commented May 7, 2016 at 10:09

3 Answers 3


Press Space and select Add Empty then Plain Axes, or add any other dummy object to your scene. Move the Empty object to your desired location using the usual G command. Then bring up the Snap menu with Shift+S and select Cursor to Selected (with access key u). Finally, press Delete to remove the Empty object.

Screenshot of the Snap (Shift+S) menu

The other techniques described in the comments (zooming in, being in wireframe mode and using Shift+S with Cursor to Grid) are quicker, whereas this technique gives you more precision.

Alternatively, you can press N to bring up the Properties pane, and manually adjust the 3D Cursor's X, Y and Z coordinates:

Screenshot of the 3D Cursor section of the Properties pane


By default, blender sets the 3D cursor using what's called the "mouse depth." When clicking in the viewport, the mouse is always over some part of the 3D scene, and that part of the scene has a distance from the camera (view plane). You have the option of using this depth value to place the cursor in the scene. If your mouse is over a face, the face depth is recorded and the cursor is placed at that depth.

Without this feature, the cursor is moved on a plane parallel to the view plane. If you set the cursor in the ortho views, you can get decently accurate placement in 3D space.

You can disable this feature in the User Preferences:

Mouse Depth

In regards to accurate cursor placement, I would recommend the snap method. Put an empty where you need it, snap cursor to the empty, then snap your mesh or object (or whatever you have) to cursor.


Press N on your keyboard when the 3D Cursor tool is activated and uncheck Surface Projection.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .