3
$\begingroup$

I followed instructions I found online. It was pretty straightforward. Just enable "Views" in the scene tab. But it doesn't seem to work for me. When I render, it just renders both left and right and then layers it on top of each other as a flat image.

I'm unable to preview or render the images correctly. Here's a video of what I did.

Is my Blender buggy or am I just doing it wrong?

$\endgroup$
  • $\begingroup$ you are changing too much options. Did exactly as your fiddling and result was as expected. I suggest, starting with a new file (since its a cube only) and change options, step by step. $\endgroup$ – Ali Jibran May 7 '16 at 8:50
  • $\begingroup$ @AliRaj I only changed one option. I enabled "Views". Everything after that was to demonstrate that it wasn't working. It was to demonstrate that the camera preview wasn't working properly, etc.. Also, this was a new file. $\endgroup$ – borring May 7 '16 at 18:51
  • $\begingroup$ well, i copied your video, and everything is working fine with me. why not reset your blender to original settings (preferences etc) and try again. $\endgroup$ – Ali Jibran May 8 '16 at 17:32
  • 1
    $\begingroup$ Can you specify what isn't working? $\endgroup$ – reden May 9 '16 at 6:10
  • $\begingroup$ @reden I'm unable to preview the stereoscopic image. I'm also unable to render it. When I render, it just renders both left and right and then layers it on top of each other as a flat image. $\endgroup$ – borring May 9 '16 at 6:41
1
$\begingroup$

It seems that the render result will always be either anaglyphic or both images overlaid. You can toggle it with one of the icons at the bottom.

Whatever stereoscopic format you choose when rendering doesn't seem to do any difference. It's when saving the result that you can choose the format. The same (or similar) panel is shown when choosing a name to save it as. (This actually makes more sense since you may want to try out or save to different formats and it would be a shame if you had to render it again.)

|improve this answer|||||
$\endgroup$
  • $\begingroup$ I don't see that icon in the viewer. Also, just to clarify, when I say preview, I meant the camera preview in the 3d viewport. Also, I don't get any stereoscopy options when naming the file after Save As $\endgroup$ – borring May 10 '16 at 21:56
  • $\begingroup$ I can get Side by Side to work with the preview viewport. By: after setting Views, go to Window/Set Stereo 3D. Anaglyphic doesn't seem to work, though. Regarding the Save options, did you render with Stereo 3D? $\endgroup$ – reden May 11 '16 at 6:12
0
$\begingroup$

When you render it out, it will always show 2 layers on top of each other. red and blue or depending which color you choose and it will be a flat image. If you have the required 3D red-blue lens goggles they give you the desired depth. But when you save it, 2 images will be saved always. you need to composite them together using photoshop or any other photo editing software you have. Normally I watch videos in 3D rendered out by blender which gives 2 videos. So I use Adobe After Effects to composite them as a final 3D video to watch with the 3D goggles.

|improve this answer|||||
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.