2
$\begingroup$

I'm trying to get fire/smoke working in Blender. I have Blender 2.77 running on Windows 7. To reproduce:

  1. Create a new file (Ctrl+N)
  2. switch to Cycles Render
  3. Select the cube
  4. Choose Object > Quick effects > Quick Smoke in 3D View header.
  5. Press Alt+A to play animation. Smoke appears as expected
  6. Go to the Physics tab on the newly created smoke object. Click on "Flow".

Smoke disappears and doesn't appear again when the animation is played again.

$\endgroup$
  • 1
    $\begingroup$ make sure you are selecting flow for the emitter and not for the domain (the larger cube that appears when you set smoke). The domain cannot be used as flow, $\endgroup$ – cegaton May 6 '16 at 18:16
  • $\begingroup$ I didn't experience that on 2.77. Make sure to re-run animation after changing type of smoke. Note that at least one domain object must be present in order animation to work. Note that if changing type of smoke object for domain, its settings will be lost. $\endgroup$ – Mr Zak May 6 '16 at 18:32
5
$\begingroup$

For smoke to work you need at least two things:

A Smoke Flow Object, the source where the smoke is generated from.

A Smoke Domain that contains the smoke simulation.

When you select an object and apply Quick smoke, a new object appears. That "newly created object" is the smoke domain.

If you convert the smoke domain to flow, the smoke simulation will not work. To change the flow settings select the original object.

$\endgroup$
  • $\begingroup$ I literally just figured this out, thanks to this page darkscarab.com/view/38 . I skipped the crucial crucial step where they click on the emitter in video tutorials, it wasn't obvious! $\endgroup$ – Steve May 6 '16 at 20:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.