0
$\begingroup$

I use this ffmpeg function to record an area of my screen for upload to youtube.

    function req()
    {
      ffmpeg -an -f "x11grab" -framerate "120" -video_size "2594"x"1458" -i :0.0+5,+257 -c:v "libx264" -crf "16" -bf "2" -flags "+cgop" -movflags "faststart" -pix_fmt "yuv420p" -preset "ultrafast" "$1".mkv
    }

I get the output video and directly upload it to youtube, it processes and I have access to 1440p resolution.

The problem is the video needs some editing, mainly removing some junk clips at the beginning and the end.

After I edit the video in blender vse and upload it to youtube, the highest resolution is 1080p.

here's the export settings enter image description here enter image description here

I've even tried to export it at h.264 lossless but I still have the video only exported as 1080p.

here's the raw video uploaded: https://www.youtube.com/watch?v=2NzSlo3knbk going through blender vse: https://www.youtube.com/watch?v=LYUTu6UV5ug

This is probably user error but why can't I get 1440p again after exporting the video from blender vse?

$\endgroup$
  • $\begingroup$ The original has options to 1440p, the blender edited version has settings up to 1440p 60fps. Possibly youtube did some serverside conversion, which took time. $\endgroup$ – Leander Nov 6 '16 at 3:46
1
$\begingroup$

I have noticed that sometimes youtube get finicky about its actual resolutions it uploads and can be inconsistant if you dont fit to their resolution standards (sometimes it works, sometimes it doesnt).

As in, resize to 2560 x 1440 and try uploading then... List of supported resolutions is here -- https://support.google.com/youtube/answer/6375112

$\endgroup$
  • $\begingroup$ I read that before and tried it but it doesn't make a difference. I will have to try to export images and use ffmpeg to encode it with the settings in the code sample in my original question. $\endgroup$ – user1610950 May 9 '16 at 18:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.