5
$\begingroup$

The clipping field under Camera > Lens is high enough to not clip just about anything, but this image still looks exactly like it's been clipped. The N-panel > View Clip field is up just as high. What am I missing?

clipped blender image

Edit: The issue disappeared when I moved the origin of a couple of objects that are pieces copied from much larger objects in another file. They had been a few hundred units away, and I moved them with Object > Transform > Origin to Geometry. However, the clipping distance was much larger than this. I'd saved after that fix, but was able to recover the session and save it for the purpose of uploading it for review, as Mentalist suggested. Cheers!

$\endgroup$
7
  • $\begingroup$ Does this only happen when you're in the camera, or even when you look around outside of it? $\endgroup$
    – Luka ash
    Commented May 5, 2016 at 23:55
  • $\begingroup$ @Lukaash only when in camera mode. $\endgroup$
    – kim holder
    Commented May 6, 2016 at 0:00
  • $\begingroup$ Now when you say "clipped" what do you mean? Because it looks fine from here. $\endgroup$
    – eromod
    Commented May 6, 2016 at 0:08
  • $\begingroup$ The vast majority of it isn't visible. The light colored walls continue on quite a distance, there are several more units with the round windows, but there is a line cutting through it and everything behind it doesn't show. Looks exactly like clipping. $\endgroup$
    – kim holder
    Commented May 6, 2016 at 0:11
  • 2
    $\begingroup$ You know what seems to have fixed it? Moving the origins of a couple of objects. They were bits cut out of much larger objects and their origins were far away. Not that far though, that a clipping End setting of a million would still not be far enough. I struggle a bit to get cameras where i want them and behaving like i'd like, but i have a passing familiarity with them. $\endgroup$
    – kim holder
    Commented May 6, 2016 at 0:19

1 Answer 1

2
$\begingroup$

The issue is indeed with the camera clip point, but you are moving the settings for the wrong camera!

You have several cameras in your scene, but only one of them can be the active camera. In your particular scene the active one called "camera".

enter image description here

You are moving the clip setting for camera.001, which is not the active one...

Set the clip settings for the Active Camera and everything will be fine!

enter image description here

$\endgroup$
1
  • $\begingroup$ Ha! (facepalm)... $\endgroup$
    – kim holder
    Commented May 6, 2016 at 13:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .