0
$\begingroup$

I´m trying to model a race track using a bezier curve, but, when I add modifiers -> array -> curve I get this :

enter image description here

What should I check for to get the mesh following the curve correctly ? Thankyou

$\endgroup$
  • 1
    $\begingroup$ can you upload the .blend? $\endgroup$ – eromod May 3 '16 at 23:17
  • 4
    $\begingroup$ Such offsets are often related to origins mismatching. Could you show where is each object's origin? $\endgroup$ – Carlo May 3 '16 at 23:21
3
$\begingroup$

As mentioned by Carlo, looks like the mesh and the curve don't share the same exact origin coordinates in the scene.

Make sure the have the same origin, and that the origin of the mesh object is sanely placed relative to it's geometry.

With the mesh object selected Shift + Ctrl + Alt + C > Origin to Geometry, or manually place it where you want it using your 3D cursor and then Shift + Ctrl + Alt + C > Origin to 3D cursor

After that make sure your object is aligned with the curve by selecting the bezier, Shift + S > Cursor to Selected, then select your mesh Shift + S > Selection to Cursor.

Optionally if you want a simple circular section consider using the bevel option directly on your track curve, or for more complex shapes perhaps a 2D bezier curve in the shape of the section of your road/track.

EDIT Upon further inspection to your file there seems to be something wrong with that bezier curve object, not quite sure what it is exactly, but whatever it is it's messing up the curve modifier.

Anyway to solve whatever problems you are encountering follow all the above steps, make sure your track curve has its origin at the scene center (world coordinate 0,0,0) by pressing Shift + C to center the cursor, then Shift + Ctrl + Alt + C > Origin to 3D cursor

Now clear all the transforms on or "section" mesh with Alt + G and then clear scale with Ctrl + A > Scale. Make sure it is centered in the scene origin just like the track's origin.

To "fix" your bezier curve track, whatever is messed up about it, just add a new spline object, Shift + A > Curve > Bezier and join the original to this new one (not the other way around) by selecting the track spline, then the new one and pressing Ctrl + J.

Then enter edit mode and delete the new small unwanted segment. If you now rebuild your modifier stack in the mesh now it should work ok.

Track fixed

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.