1
$\begingroup$

So I was just using blender 3D modelling and I decided to take 6 objects and join them together using CTRL + J and suddenly the program just slowed down real hard.

What is the cause of this please and is there a way to fix this? Do I have to delete my object again?

$\endgroup$
  • $\begingroup$ Do some of your object have any modifier? $\endgroup$ – Carlo May 3 '16 at 17:02
  • $\begingroup$ prntscr.com/azulx2 This is a screenshot of 6 objects which I joined into 1. All It had was a subdivision surface $\endgroup$ – Cyanic Wolf May 3 '16 at 17:54
  • 1
    $\begingroup$ You can see at the top of the page that the scene has like, 41 million verts. you've done something to make this happen. It is possible that one of the meshes you joined has a really dense topology already. This, combined with the level 4 (!!!) subsurf is giving you unnecessary detail, and your lag. $\endgroup$ – Scalia May 3 '16 at 20:03
4
$\begingroup$

If you look at the info shown at the top of your window, your scene has 40 million vertices, that is why things are slow.

info panel

You probably had a subsurf on one object but when you joined them together the subsurf then became active on the new denser mesh.

As you have a subsurf division setting of 4, that means you have about 150,000 real vertices or 25,000 vertices in each original object. With the subsurf at 4 divisions on only one of them, you would have had 6.8 million vertices before joining. That jump from 6.8 million to 40 million will be the reason for the performance difference.

Solutions:

A subdivision setting of 4 is high, dropping it to 2 will give a similar visual result with only 2.5 million vertices.

From what I can see of your object, 157,000 vertices for each item is extremely high. I would expect to use less than 200 vertices for a shape like that. Adding a subsurf with a division of 4 on 6 of the lower poly objects would leave you at about 300,000 vertices which will be very fast to work with.

$\endgroup$
  • 1
    $\begingroup$ Also since the objects seem to have a long flat surface, limited dissolve might help to bring down the number of vertices without affecting the overall shape. $\endgroup$ – cegaton May 3 '16 at 21:11
  • $\begingroup$ 40 million :o? Thats over 9,000!!!! $\endgroup$ – eromod May 3 '16 at 21:16
  • 2
    $\begingroup$ To understand how the number of subdivisions can grow very quickly read: blender.stackexchange.com/questions/15654/… $\endgroup$ – cegaton May 3 '16 at 21:53
  • $\begingroup$ I see. I think best solution here is to remove the sub surface and use smooth instead. It has a similar effects and there isn't much change to the object. Thank you very much every1 for your feedback. I found it helpful :) and yes I shouldnt have done a subsurf of 4 that was stupid of me. I just never knew that sub surf would create such lag $\endgroup$ – Cyanic Wolf May 5 '16 at 11:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.