I'm very new to blender. I animated this model:


I want to use this animation in a video. I use chroma key to take away the background but it's impossible to do this when the green color from the background reflects on the door(see image). I did change the Environment and Indirect lighting but it did'nt help. I tried many things but nothing worked. Can someone help me out?

EDIT I'm in blender render mode.

  • 4
    $\begingroup$ Using a green background is completely unnecessary. You should be able to export a clean alpha channel out of blender. $\endgroup$
    – user1853
    May 2 '16 at 16:49
  • $\begingroup$ If you wan't to use a video format that doesn't support alpha, you can also render out a black and white matte. $\endgroup$ May 2 '16 at 17:37

You Don't have to use chroma,You can just render the video in alpha channel.


To do so,You just have to check transparent film panel: T

This will render the background as Alpha but the reflections will be still here.

To remove the colored reflection,Uncheck use Environment in render layer:


Blender Internal:

You just have to Uncheck Sky in render layers:


  • $\begingroup$ Thank you, but is it possible too in "blender-render"? $\endgroup$ May 2 '16 at 16:11
  • $\begingroup$ Sorry, I did already: same result $\endgroup$ May 2 '16 at 16:25
  • $\begingroup$ You did the process under the blender Internal?Can you add another screenshot after the Sky checked? $\endgroup$
    – Omar Emara
    May 2 '16 at 17:37
  • $\begingroup$ -1 This doesn't actually answer the asked question. Adding alternate suggestions for a better method to achieve an end result is okay; however, answering the actual question is also important, since other people may read this question and still want to achieve, for different reasons, what the question originally asked to do. $\endgroup$ May 2 '16 at 17:54
  • $\begingroup$ @GiantCowFilms I answered the question without any alternatives,he never said anything about file format,Most of us probably render a PNG image sequence not a video anyway. $\endgroup$
    – Omar Emara
    May 2 '16 at 18:03

I believe what you are trying can be accomplished by turning off everything except Camera in the ray visibility window in the world menu.



For anyone who still sees this in Blender 2.8: go to Materials -> Surface and there you can set the strength to "Is Camera Ray".


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.