5
$\begingroup$

I moved the object below with the grab tool and the origin did not update.
Origin not updating
This occurs whenever the object is moved (with any transform tool, in any manner). Nothing in this scene has parenting.

I believe that this issue may have been aggravated by repeated use of setting the 3D cursor position, then setting object origins to it. As a matter of fact, they move together!

Here are some things that I tried to remedy the situation, none of which worked:

  1. Setting the object's origin to its geometry
  2. Clearing object origin
  3. Applying transforms
  4. All items under the "snap" and "set origin" menus.
  5. Selecting different objects (the origin never moves... it might still be the origin of the object in the picture)
  6. Selecting/deselecting all objects
  7. Saving to a different file and opening.

As, err, intriguing as it is that the origin is permanently locked into the 3D cursor's place, I want to know if anybody can find a solution to this.

$\endgroup$
  • $\begingroup$ Note that the object origins (the yellow/orange dots) actually did move, the 3D cursor and manipulator handles are the things which did not move. $\endgroup$ – gandalf3 Nov 30 '13 at 7:39
  • $\begingroup$ Perhaps you have a decimate modifier on the objects containing the replacement meshes, in this case remove the modifier. $\endgroup$ – atevm Jun 6 '15 at 12:31
6
$\begingroup$

This is because your pivot point is set to 3D Cursor.

enter image description here

To have the 3D manipulator widget move with the model and not stick to where the 3d cursor is, you can use the default Bounding Box Center or just press , (comma). If you work with both, you can also use its shortcut . (period) to quickly switch between them.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.