1
$\begingroup$

Please note: I realize this question is very similar to this one but I assert that it is not a dupe because it involves specific a hardware/OS combo! More importantly, this question is really about Mac laptop usage of a particular Blender feature, not necessarily about closing the default cube.

If you downvote or closevote this as a dupe, I at least ask that you add a comment that might help steer me in the right direction! But if you can't think of anything that would help me, then clearly this is a new aspect of an existing question, and I argue that this is grounds for this question being legitimate and not a dupe!!!


I am trying to get "the default cube" to go away on startup. Yes, I realize that once I remove it, that I can just update my default settings by entering Ctrl+U. That's not what I'm asking here.

In the answer to the question I linked above, the user stated that to remove the cube, select it by using the RMB (Right Mouse Button), then clicking X.

But on a Mac laptop, I have no right mouse button (RMB). All I have is a mouse pad. When I select the cube by clicking on it, all of the following have the same effect:

  • Clicking the cube on the left-side of the mouse pad
  • Clicking the cube on the right-side of the mouse pad
  • Hitting the Control button, and then clicking on the mouse pad
  • Hitting the Command button, and then clicking on the mouse pad

In all 4 of these scenarios, once I make the click on the mouse pad, and then hit X, I see the following screen:

When I click and press the X key

When I select the Delete option, nothing happens. Where am I going awry?!?

Update:

I am in "Object Mode", but I noticed that when I click the cube it does not seem to be actually selected. That is, the cube does not have a thin orange border surrounding it. I think this is an important clue.

$\endgroup$
  • $\begingroup$ Only a fool would downvote this question. $\endgroup$ – smeeb Oct 7 '16 at 8:47
  • $\begingroup$ Just as a note, CTRL+Clicking emulates a right-click on most MacOS products. $\endgroup$ – Josh Silveous Jan 19 '17 at 15:46
4
$\begingroup$

Yeah, it must be selected.

To select it with no RMB, you must change your user settings.

enter image description here

Now go to the "Input" tab and change to LEFT for select

enter image description here

$\endgroup$
2
$\begingroup$

Firstly, it's just a right-click. Macs "right-click" too. Whether it's the right side of the pad, two-finger tap, or holding another key while you click, it's all the same. Whatever way you "right-click" on a link to "open in a new tab," or "right-click" to cut/copy/paste use the same thing here.

Secondly, you could change the interface to use Left-Click to select. You can do that in the user preferences -> input tab -> "Select With..." While this might solve your problem at first, it might make following tutorials a bit more difficult. Also... you're still eventually going to have to right-click something in Blender.

The last option is to turn on "Emulate 3 Button Mouse..." in that same part of the User Preferences. This will cause "left-click" to become "right-click" but only when you hold the Alt key. It has some similar problems as "left-click to select." There are 1 or 2 commands that are impossible with the mouse if you use "Emulate 3 button mouse," but they're super obscure and there are still other ways to do them. Some other commands turn into a form of keyboard gymnastics, trying to hold Alt and Shift and click and drag...

The reason that the cube isn't being deleted is that it's not selected. Select it with "right-click" and then type x or press del and it should behave as expected.

Hope that helps!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.