2
$\begingroup$

I was using blender 2.76b on a Windows 7 Ultimate, and nothing really weird showed up when I opened blender and the cmd window appeared, before the blender window appeared.

I updated it to 2.77a, and now in the cmd window, it says:

Warning! Legacy WGL is unable to select between OpenGL versions.

Is this a big issue that I would want to fix, or would it not matter?

If I should fix it, how should I fix it?

System specs:

  • Laptop: Samsung Sens R410
  • OS: Windows 7 Ultimate, was Windows Vista Home Premium OEM (according to the sticker on the underside)
  • CPU: Intel Pentium Merom T2390 Dual Core 1.87 Ghz
  • RAM: Installed 5Gb, but can only use 2.75Gb 667 MHz
  • GPU: ATI Radeon X1250 with 256Mb memory with a weird driver that has OpenGL issues. The 3d cursor moves when I drag the arrow to move an object in the 3d viewport. I think this is because I am using Vista drivers, and there are no drivers for windows 7.

  • $\endgroup$
    • $\begingroup$ The answer is in your own question: a weird driver that has OpenGL issues. Update or fix those issues. Not really a blender problem it seems. $\endgroup$ – cegaton Aug 6 '16 at 20:42
    • $\begingroup$ I know it's not a blender problem, and I can't fix it. I either have to use the generic driver from microsoft or use a vista driver(which I am using), both of which result in crappy performance. $\endgroup$ – Yubin Lee Aug 11 '16 at 7:11
    • $\begingroup$ Have you tried using Linux on that computer? Using a 64 bit version would allow you to use all of your RAM $\endgroup$ – cegaton Aug 11 '16 at 9:06
    • $\begingroup$ I did try fedora 64 bit, but there were opengl issues. My computer teacher(who loves fedora btw) installed it for me, and he gave up on my computer as well. $\endgroup$ – Yubin Lee Aug 14 '16 at 4:15
    • $\begingroup$ ... In that case... look for a new (used?) computer... $\endgroup$ – cegaton Aug 14 '16 at 4:44
    0
    $\begingroup$

    I reported this as a bug here, and the answer I got was this:

    "Your GPU is too old. You may be able to still use it if you update your drivers."

    $\endgroup$
    • $\begingroup$ This is a non-answer. My Geforce Nvidia GTX950Ti is not too old, and it's using current drivers. $\endgroup$ – Cyberchipz Jul 21 '16 at 21:16
    • $\begingroup$ Well, I have nothing to tell you. That's what one of the blender developers said, not me. $\endgroup$ – Yubin Lee Jul 22 '16 at 4:33
    • 1
      $\begingroup$ I found out, for me, the issue was a workaround I tried, that didn't work. I had left a copy of opengl32.dll in the blender directory. You might look to see if you have an old copy of an opengl32 library on you system that might be pre-empting your graphics card drivers. Or if your system is really old, you might want to place an updated opengl32.dll into that directory which 'might' fix the problem. $\endgroup$ – Cyberchipz Sep 1 '16 at 16:00
    • $\begingroup$ I don't have opengl32.dll. There was an old issue where the 3d cursor would move instead of the arrows that move a mesh, and the developers told me to put opengl32.dll in the blender directory. However, it was too laggy, and I deleted it and stuck to hotkeys instead. $\endgroup$ – Yubin Lee Sep 2 '16 at 9:10
    0
    $\begingroup$

    That is wild. I was looking everywhere for the solution to the same issue. Everywhere mentioned that you had to choose 'integrated graphics' with an Nvidea card. However I had an AMD card and it was not that old. The sluggish GUI of Blender was driving me nuts. It was the latest download (2.79).

    Turns out it was because I had issues using 2.78 with remote desktop, due to the version of OpenGL. I put a 32bit version in the same folder and it would work while using RDP. When I installed the new Blender, I had not removed that DLL file. That was it. I deleted the file and the problem cleared right up!

    $\endgroup$
    0
    $\begingroup$

    I have solved this problem by following method:
    Open windows explorer and type in %appdata% find the Blender Foundation folder and delete it.

    This might be happened due to some conflict in startup application preference.

    $\endgroup$
    • 1
      $\begingroup$ Do note that doing so will delete your startup file, user preferences, and some addons. $\endgroup$ – David Nov 24 '17 at 13:31

    Your Answer

    By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

    Not the answer you're looking for? Browse other questions tagged or ask your own question.