1
$\begingroup$

I have created a scene and set up the camera and everything looks good through the viewport camera.

enter image description here

then when I hit render and the result is a warped version of what is seen through the camera.

please help

enter image description here

$\endgroup$
  • 1
    $\begingroup$ Are you using a subsrf modifier on the background purple and black elements? Are the camera clipping settings correct? Can you post more info or make the file available to download? You can use blend-exchange.giantcowfilms.com/help to upload. $\endgroup$ – cegaton Apr 29 '16 at 13:58
3
$\begingroup$

You have a Subsurf Modifier applied to the plane that you're using as a mask. Most modifiers allow different settings for preview in the viewport and at render time. You probably have the subdivisions for "view" set to zero, and the subdivisions for "render" set to 1 or 2. This is so that you can minimize impact on the viewport but still have a nice render.

Select the plane and then look in the modifiers tab. You can either adjust the subsurf settings to be more reasonable, or just delete the modifier altogether.

If you never tried to add a subsurf modifier and are wondering how in the world it got there, it's possible to add one by pressing ctrl1 or another number, up to 4 (I think). So you probably accidentally used that shortcut.

enter image description here

enter image description here

Hope that helps!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.