7
$\begingroup$

I am trying to render an animation in cycles without the background. However, every time I have it render, the background still shows up.

I used the compositor to add a background image so I can animate the object around the background. I set the output to RGBA and set the film to transparent.

Now I want to use it in After effects and I simply want to export/render it without the background and make it transparent. How do I do that?

enter image description here

$\endgroup$
  • $\begingroup$ I'm not sure what you are asking.. Are you asking how to setup the composite nodes so there is no background image, only transparency? $\endgroup$ – gandalf3 Nov 28 '13 at 21:45
  • $\begingroup$ I want to know if it is possible to have a background image but have it transparent when doing a render pass $\endgroup$ – user2883800 Nov 28 '13 at 22:05
  • $\begingroup$ You mean have the color information, but completely transparent? $\endgroup$ – gandalf3 Nov 28 '13 at 22:19
  • $\begingroup$ vimeo.com/71859089, around 6:00. he has the background but he renders it in a way that the photo is not there and is transparent or empty. The problem is all the tutorials like these use internal render $\endgroup$ – user2883800 Nov 28 '13 at 22:41
8
$\begingroup$

I'm not sure what you want, but if I understand correctly, you can make the background image color information remain in the image while still making it completely transparent.

This can be done with the Set alpha node, with an Alpha of 0:

enter image description here

However, in the video you linked to the scene is rendered without any information about the background image at all.

Here is a setup that will do this:

enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ When I render I don't want the background image. $\endgroup$ – user2883800 Nov 28 '13 at 23:06
  • $\begingroup$ @user2883800 How's this? $\endgroup$ – gandalf3 Nov 28 '13 at 23:14
  • $\begingroup$ When I render it the background is all white except the objects $\endgroup$ – user2883800 Nov 28 '13 at 23:28
  • $\begingroup$ @user2883800 Hmm.. Is Transparent still enabled in Render > Film? Is the ColorRamp stop set to transparent? If those are correct, could you upload the .blend? $\endgroup$ – gandalf3 Nov 28 '13 at 23:40
  • $\begingroup$ nevermind it works now, I didn't make the colorRamp transparent $\endgroup$ – user2883800 Nov 29 '13 at 3:32
2
$\begingroup$

You can render an image with a transparent background without compositing.

For cycles you enable a transparent background in the Film panel -

enter image description here

The same result can be achieved in Blender internal under Shading by choosing transparent instead of Sky for Alpha -

enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ The OP already enabled Transparent (from the question: "I set the output to RGBA and set the film to transparent"), I think he/she wants to know how to include the shadows from the other renderlayer shown in the screenshot. $\endgroup$ – gandalf3 Nov 29 '13 at 5:22
  • $\begingroup$ Yes for BI this will give you what you want as you can set shadow only for material but cycles you have to composite shadows. $\endgroup$ – sambler Nov 29 '13 at 5:33
  • $\begingroup$ Right. Then if I understand it, this answer does not answer the question? $\endgroup$ – gandalf3 Nov 29 '13 at 5:35
  • $\begingroup$ I found a video that solve the problem but part of the solution was making the color in ColorRamp transparent. $\endgroup$ – user2883800 Nov 29 '13 at 16:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.