1
$\begingroup$

I am quite new to Blender and I don't know if this is some setting I messed up or a bug.

When I use walk mode/fly with Ctrl+F it all works fine, but when I want to stop and go inside a wall for example and stop to look at a certain detail the camera always jumps a bit behind where I am and down... I have looked everywhere in the User Preferences and found nothing to change this jump.

When I create a new Blender project walk mode works as it should again. It gets really frustrating since I can never position myself with walk mode, I always end up inside a wall or somewhere so that I can't see the detail I am trying to work with.

Example Screencast
Here you can see me trying to look at the edge of the building. When I stop flymode/walkmode, it pushes me into the edge.

$\endgroup$
3
$\begingroup$

I'm using blender 2.78a. I've been dealing with the same issue, and I found a work around.

If I zoom all of the way in before entering fly mode, the "jumping" no longer occurs. If I zoom out before entering fly mode, the "jumping" gets worse.

$\endgroup$
1
$\begingroup$

If you RMB click it cancels Fly Mode and resets the view (jumps) back to the starting position.

If you LMB click it accepts your new new position.

Note: in newer versions of Blender the key combination has been changed to Shift+F

https://www.blender.org/manual/editors/3dview/navigate/index.html

https://vimeo.com/9567714

$\endgroup$
  • 1
    $\begingroup$ Hmm yeah but my problem is that my left click is jumping me back just a bit, enough to displace me when iam doing detail work :/ $\endgroup$ – Ganonflake Apr 26 '16 at 19:49
  • 2
    $\begingroup$ @Ganonflake you may need to include a screencast/gif of the problem; I'm not able to replicate that here with Fly/Walk. $\endgroup$ – Jonathan Williamson Apr 26 '16 at 19:52
  • $\begingroup$ There's a possibility that this problem is related to the mouse itself, specially if you have a mouse software, could be conflicting with Blender, I had the same issue in different software, are you sure this glitch happens only in Fly mode? $\endgroup$ – Georges Apr 27 '16 at 3:22
  • $\begingroup$ @Georges This happens in both walk and fly mode. Everything works fine while flying/walking but when i stop it always pushes me in some direction, sometimes the "jump" is longer then other times. With a new project this jump is not present, everything works fine then, maybe i should just move all my content to a new blender file... I will upload a gif in a moment! $\endgroup$ – Ganonflake Apr 27 '16 at 7:06
  • $\begingroup$ Try confirming with Enter button instead of left mouse button, just to isolate the purpose $\endgroup$ – Georges Apr 27 '16 at 9:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.