1
$\begingroup$

I'm using Blender's internal renderer, trying to get some transparent shadow using a spot light with deep or irregular buffer switched on. Contrarily to this answer, the manual for 2.77 states this about the Irregular Buffer:

This method supports transparent shadows. To do so, you will first need to setup the shadow setting for the object which will receive the transparent shadow.

and this about the Deep Shadow Buffer:

Deep Shadow buffer supports transparency and better filtering, at the cost of more memory usage and processing time

(That last bit is even in the button's tooltip.)

Yet, when I map this png image onto a plane:

Orange circle with alpha channel

then switch my light to spot and the shadows to deep/irregular buffer, making sure that the plane underneath is set to receive transparent shadows, I do not get transparent shadows, but this:

render result

So my question is, is there any extra step needed to get it to work, or is the feature broken, or am I missing something or what?

$\endgroup$
  • $\begingroup$ Blender internal works in mysterious ways.. select the objects that receive the shadow and enable receive transparency $\endgroup$ – cegaton Apr 26 '16 at 22:38
  • $\begingroup$ As mentioned in the question, I have done that, but still no transparent shadows... $\endgroup$ – wilks Apr 28 '16 at 17:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.