9
$\begingroup$

I have a 3-D mesh of a human head (mine!), ~100K vertices. I'm attempting to simulate soundwaves entering the ears.

The simulator's memory requirement shoots up as the vertex count increases by O(N^2)

So I need to massively reduce the vertex count. However, I need to keep the highest level of detail for the ears.

One approach might be to separate off the ears, and reduce the remaining mesh, then put it back together again.

Another approach might be to create a script that receives the xyz coordinates of each ear (maybe I can choose a point right at the entrance to the ear canal) and automatically merges vertices that far away from both foci.

Or maybe there is another approach?

Please do bear in mind that I've only ever use Blender once, and that was for something trivial: changing the file format of a mesh, so please don't hold back!

$\endgroup$
  • $\begingroup$ I have a similar problem, but I actually want to do exactly what this question title requests. Neither of the answers quite address the question as posed in the title. I want a gradual increase in mesh face area / edge length as a function of distance from a point. Hope someone will add another answer to this question that describes how to do that. $\endgroup$ – foobarbecue Apr 7 '16 at 2:36
9
$\begingroup$

If all you need is to reduce vertex count, and not care much about the topology, you may consider use Decimate modifier, and control the modifiable area by vertex group.

Method 1:

enter image description here

Method 2:

  • Select the ears, then CTRLI to select the invert part;
  • X > Limited Dissolve to dissolve elements for mesh simplification in a relatively cleaner way.
  • Press F6 for further tweaks.

enter image description here

P.S.: Limited Dissolve gives same result as the Decimate Modifier by using its Planar mode. So you can use both.

(Head model came from Sintel project)

$\endgroup$
  • $\begingroup$ Finally I've tried this out. Dissolve is no good to me, as I need triangles note n-gons. Decimate looks perfect, but it won't decimate in edit mode. And if I switch to object mode and then decimate, it decimates the entire model, rather than just the selected region... $\endgroup$ – P i Dec 15 '13 at 4:05
  • $\begingroup$ You can easily triangulate the n-gons with a modifier or in edit mode. $\endgroup$ – Andy J Buchanan Jun 5 '14 at 10:24
9
$\begingroup$

Another option is to use Sculpting with Dynamic Topology.

  1. Enter Sculpt Mode in 3D view > Header

  2. Enable Dynamic Topology (CtrlD) in Tool Shelf (T) > Topology:

    enter image description here

  3. Set the brush tool to Simplify in 3D view > Header > Brush > Brush Tool:

    enter image description here

  4. Sculpt on the mesh to remove detail. You can adjust the Detail Size in 3D view > Tool shelf > Topology to change the level of detail the brush paints. Note that this value is in pixels, so it is view dependent. (The more you zoom out the lower the level of detail is)

    Update: as of 2.71, there is now a constant detail option which is not dependent on zoom. There is also a detail picker, so you can set the detail based on the density of existing faces.

Example:

enter image description here

$\endgroup$
  • $\begingroup$ Thanks a lot for this answer! :) It's the exact solution to my problem. $\endgroup$ – Stephanie Platz Apr 16 '15 at 0:06
  • $\begingroup$ This is great. In 2.79 Dynamic Topology is under Tools panel > Dyntopo $\endgroup$ – Justas Jul 24 at 16:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.