5
$\begingroup$

The screenshot below says it all, really. The object is offset in both the X and the Z axes, though only the X axis says 1. No other modifiers are on it, no constraints, no locked axes, and I can't think of anything else that would affect this. How can I make it stop doing this?

enter image description here

$\endgroup$
  • $\begingroup$ This looks like a problem with the object's origin point. Try pressing Shift + Ctrl + Alt + C while the object is selected and click on "Origin to Geometry" to see what happens. $\endgroup$ – RobotUnderscore Apr 24 '16 at 22:04
  • $\begingroup$ Nope. I tried it, and the origin is now in the center of it, but it does the same thing. :/ $\endgroup$ – kim holder Apr 24 '16 at 22:07
  • $\begingroup$ What happens when you set the X value to 0? $\endgroup$ – RobotUnderscore Apr 24 '16 at 22:14
  • $\begingroup$ It snaps onto itself like you'd expect. When i set just Z to 1, it moves down by one and along the X axis by 0.5. (??) $\endgroup$ – kim holder Apr 24 '16 at 22:17
  • $\begingroup$ Oh hey - when i clear rotation, it turns 90 degrees around the Z axis and 45 around the Y axis... so i guess i have to put it in the position i want and make that the 'cleared' position? $\endgroup$ – kim holder Apr 24 '16 at 22:22
5
$\begingroup$

You have rotations and scaling settings that are interfering with the Array modifier.

Press Ctrl + A with the object selected in Object Mode and click on Scale in the menu that comes up to set the default scale of your object to its current size, and repeat this with Rotation to set the current rotation of your object to the default rotation.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.