1
$\begingroup$

My scene contains transparent objects that pass through each other during the animation but it seems to be casting a shadow when the overlap

I've attached a screenshot if anyone can help.

enter image description here

enter image description here

enter image description here

$\endgroup$
5
  • 3
    $\begingroup$ Although that isn't exactly related, do not plug output from Normal Map node into Displacement input socket of Output node; use Normal input socket of Diffuse node instead. See blender.stackexchange.com/questions/16443/… $\endgroup$
    – Mr Zak
    Apr 22, 2016 at 12:17
  • $\begingroup$ you can always just turn off cast shadow in the object menu, and animate that too $\endgroup$
    – Allofyoush
    Apr 22, 2016 at 12:49
  • 4
    $\begingroup$ that looks to me like overlapping geometry and errors produced by Z-fighting, but without access to the file is hard to tell what the issue is. $\endgroup$
    – user1853
    Aug 21, 2016 at 6:23
  • $\begingroup$ are you sure this is caused by the transparent objects? does the artifact disappear when you hide them on a layer which is not being rendered? $\endgroup$
    – aliasguru
    Aug 21, 2016 at 17:17
  • 6
    $\begingroup$ That's z-fighting, not a shadow. You have some overlapping geometry there. $\endgroup$
    – PGmath
    Sep 20, 2016 at 13:55

1 Answer 1

0
$\begingroup$

Use this node setup to disable cast shadows:

enter image description here

$\endgroup$
1
  • $\begingroup$ Sorry, its still doing the same thing. I have updated my question with a screenshot of my node setup if thats helps $\endgroup$ Apr 22, 2016 at 10:12

Not the answer you're looking for? Browse other questions tagged .