I am trying to learn texture baking work flow using Cycles, I checked the manual and a few forum threads on the topic.

So, I have a lowpoly and a highpoly objects, both are UV-unwrapped.

I setup some material for highpoly object with color and displacement, both objects have the same location, I use "Selected to active" option, tried cage settings etc. Tried scaling hipoly object down, so that it is completely inside the target lowpoly object. But no matter what, I get these strange maps rendered. can anyone advise what am I doing wrong?

I also noticed that objects are rendered with flat shading whether or not I select "smooth" option.

Many thanks in advance.

UV Map mesh view rendered view bake settings diffuse bake settings normal baked texture - diffuse baked texture - normal

  • $\begingroup$ Did you try to recalculate the normals? Ctrl+N $\endgroup$ – Delagone Apr 21 '16 at 11:56
  • $\begingroup$ Did you set Smooth shading before baking ? Also try selecting all in Edit mode and remove doubles via W menu, $\endgroup$ – Mr Zak Apr 21 '16 at 12:31
  • $\begingroup$ Thanks for suggestions, I will try everything (even though I believe I did all these) and post updates. $\endgroup$ – B-and-P Apr 21 '16 at 13:02
  • $\begingroup$ This can is resulted from two overlapped UV's or 2 linked objects. make sure you only have 1 UV in place and remove doubles. $\endgroup$ – Omar Emara Apr 21 '16 at 15:01

Usually, this happens when the two meshes are intersecting. Avoid this enabling the cage option into the bake panel and set a distance maybe 0.05 (5 cm) in your case should do fine.

A normal map has mostly a blue tint indicating the z direction that the faces are pointing towards, In your case, as the meshes are intersecting you get this strange variation of colors because sometimes the hires mesh is on one side of the low res mesh, sometimes is on the other side.

Creating a cage (and not choosing an object as a cage) is like inflating your low-resolution mesh and projecting towards inside from a certain distance to find the high res object.

If you have a complicated shape and usually the concave shapes that simply "inflating" it makes it intersect with herself might need a cage object ( with the same number of verts as the low res object).

Also, shade smooth your high-resolution object.

P.S. You might want also to give a bit more distance between the two UV islands as they might overwrite each other.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.