42
$\begingroup$

I am new to Blender. I downloaded a .obj file of a plant model. When I unzipped it I found two files (.obj and .mtl). I imported the .obj file and I couldn't do the same with the .mtl to apply the material and the textures.

$\endgroup$
3
  • 3
    $\begingroup$ When you import the obj it should read the associated .mtl file by default. Are you sure you aren't in wireframe view? Press Z to toggle this on/off. $\endgroup$
    – iKlsR
    Nov 25, 2013 at 15:07
  • $\begingroup$ i am having a similar problem where the mtl is showing in the 3d view but not in the rendered view. i cannot find an answer for this anywhere $\endgroup$
    – user3006
    Apr 3, 2014 at 5:00
  • $\begingroup$ @swim You probably don't have a texture on the object. $\endgroup$
    – iKlsR
    Apr 3, 2014 at 16:07

1 Answer 1

39
$\begingroup$

When you import the .obj file, Blender will also import the associated .mtl file* by default as well which is usually the same name. The colors applied to the model will show in the viewport and to see the texture(s) (if any), enable texture shading with AltZ.

* This is the file that should be generated alongside the obj when it was created and will hold color data and paths to textures if any. Opening the obj file in a text editor should show this near the top.

$\endgroup$
2
  • 3
    $\begingroup$ Also note, the textures won't show in the model editor. You need to go to "Shading" to see them $\endgroup$ Jan 24, 2021 at 13:33
  • $\begingroup$ You may need to edit the plain text .mtl file. I just ran into this as the delivered .mtl file referred to two texture images with a hard coded Windows path. $\endgroup$ Dec 14, 2021 at 1:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .