1
$\begingroup$

This is only occurring with this one .blend file I'm working on. For some reason rendering the image using Blender Render doesn't give me a fully-rendered version of what I've got in the active camera. Instead it results in a single, flat picture of a texture while OpenGL rendering is giving me the expected result.

Normal render result vs. OpenGL render result

Any ideas on what settings might be causing this?

.blend file can be downloaded here: dof-test.blend

$\endgroup$
0
$\begingroup$

Something is broken with the texture definition of "mike_ironfist_advance_sprite_idle_512h". I don't know exactly what because I created new texture identical to the existing, it renders the material and texture preview fine and works in actual render unlike the existing texture.

$\endgroup$
  • $\begingroup$ Ah, this seems to be the solution that still allows the viewport preview to appear correctly! I just did what you did (added another texture using the same image as the original) and it worked without issue. Thanks a lot! $\endgroup$ – Mike IronFist Apr 21 '16 at 5:26
1
$\begingroup$

You need to enable Face Textures and Face Textures Alpha

enter image description here

And uncheck color as influence

enter image description here

$\endgroup$
  • $\begingroup$ Great! That did indeed make the texture show. I don't know what broke the texture in the first place but this definitely fixed it. Thanks for the help! $\endgroup$ – Mike IronFist Apr 21 '16 at 5:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.