1
$\begingroup$

I have a collection of planes with different designs and changing their material isn't reflected in solid view in both blender internal and cycles render view. The materials I'm trying to use have been working fine for other objects.

All the planes have once been set to a pure shadeless black texture, and have had a Solidify modifier applied to them. The rendering isn't fixed after removing the modifiers. Flipping the normals doesn't have any effect.

The vertices of the planes act weird. If I add an edge, one of the triangles will be colored according to current material. If I then dissolve the new edge, it will also delete the points, even though they should be connected to the other points.

Dragging a point so the plane is self-intersecting will cause the material to display properly. Plane's material is rendered correctly when the face intersects itself

Also, the plane is rotated along the Z axis. If I Scale the plane (in object) by 1 (or anything), it will automatically align itself along the X axis (the way it previously was).

I tried to rebuild the points of the plane, and I'm not able to align/snap points to the vertices of the plane in edit or object mode. Also, I can't split the plane using the Knife tool

Currently, the only solution I have is to trace the planes.

Blender source file containing some of the planes.

$\endgroup$
  • $\begingroup$ You should include a source file. It helps to get your question answered more quickly. The problem could have multiple options to fix the issue so I'd definitely recommend posting your .blend $\endgroup$ – Delagone Apr 19 '16 at 7:55
0
$\begingroup$

The problem is you need to apply your scale transforms on the objects. The reason the faces are shading poorly is because of Z-fighting, which is occurring because your objects have zero Z scale value. Applying scale will also allow your modifiers to work.

To apply the scale, select all your objects in object mode, press Ctrl-A and Scale. Or in the viewport header, Object -> Apply -> Scale

Your scale values should now read 1.0, 1.0, 1.0.

Apply Transforms

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.