0
$\begingroup$

I am trying to combine a shockwave (edited in the render layers compositor) with the rest of the composition (currently a torus). I do not know how to add the shockwave to the rest of the scene. I do not want the particle system to be visible, just the shockwave effect generated from the particle system. This is the shockwave and my current non-effective node setup:

enter image description here

enter image description here

Here is the current render... The torus and the particle system, but no shockwave. At one point I had managed to add the shockwave to the particle system, but I do not want to see the particle system.

enter image description here

Thank you for any help!

Here is the .Blend file:

EDIT in response to Cegaton's answer:

I set everything up and for some reason "Views" is not where to put Torus and Particles on my computer. However, the torus is the only object showing up in the render, and I think it has to do with the missing AO checkbox:

enter image description here

You can see there is no checkbox for Alpha Over and I am guessing this is why it is not working in the render? I checkmarked "AO" in "Passes" but I think this is not the same thing, since it is not working.

Thank you for advice!

Here is what "Views" is like on my computer:

enter image description here

That's why I was confused for a while!

EDIT !

Big problem solved! I needed to click "transparent" under "Film" under "Render" (the little camera icon). Now the render layers nodes have checkered backgrounds and everything seems to be working properly!

$\endgroup$
  • $\begingroup$ It would be easier to help you if you upload your scene. use blend-exchange.giantcowfilms.com and edit the resulting link into your question. $\endgroup$ – cegaton Apr 17 '16 at 3:49
  • $\begingroup$ I think you may want to use layers & render layers. $\endgroup$ – Rick Riggs Apr 17 '16 at 4:09
  • $\begingroup$ and alpha over... $\endgroup$ – cegaton Apr 17 '16 at 4:56
  • $\begingroup$ @cegaton Here is the file, thank you for help. $\endgroup$ – WishyQ Apr 17 '16 at 6:44
2
$\begingroup$

It is unclear to me what you mean by shockwave, but here's what I think.

For better control separate the different elements in different layers.

enter image description here

Then set different render layers, so that the particle layer excludes the torus and the layer for the torus excludes the particles.

enter image description here

Then mix them in the compositor using alpha over, you won't need the material index:

enter image description here click on the image to enlarge

enter image description here

$\endgroup$
  • $\begingroup$ The ring of flame is going to be a "shockwave", sorry for confusion! Thank you for your answer, I am going to try this now. :) $\endgroup$ – WishyQ Apr 17 '16 at 23:30
  • $\begingroup$ I apologize for perhaps foolish question, but how did you get "particles" and "torus" into "Views"? Mine just says "left" and "right". How do I get "use AO" to appear in the "Layer" box? Thank you! $\endgroup$ – WishyQ Apr 18 '16 at 0:47
  • $\begingroup$ please read: blender.stackexchange.com/questions/33897/… $\endgroup$ – cegaton Apr 18 '16 at 1:52
  • $\begingroup$ OK, thank you, I also added an edit to my question, now i am just wondering where the "AO" checkbox is. $\endgroup$ – WishyQ Apr 18 '16 at 1:54
  • $\begingroup$ @WishyQ scroll down using the bar on your right. i.stack.imgur.com/7TxPg.gif $\endgroup$ – cegaton Apr 18 '16 at 1:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.