3
$\begingroup$

I can not seem to gt rid of the really annoying BLACK that always seems to show up in Blender Cycles when rendering glass. I've even used a transparent shader to NO avail.

enter image description here

$\endgroup$
  • 1
    $\begingroup$ See if it helps - blender.stackexchange.com/questions/2558/…. It could be not enough transparent bounces or not proper rendering of caustics $\endgroup$ – Mr Zak Apr 16 '16 at 22:08
  • $\begingroup$ Thanks. I increased the transparency from 8 to 20 (both Min / Max) I increased bounces to 12 (both Min / Max) --absolutely no change. I inceased the IQR from 1.4 to to 2.0 nano change. $\endgroup$ – Marc Apr 16 '16 at 22:48
2
$\begingroup$

Here's a material fix that I applied that seemed to head toward what you were wanting. Same basic components, just re-arranged a little.

enter image description here

I think you can get your reflections back using a method something like this afterward:

enter image description here

If you want to get even more of the reflection back you can just keep the progression of your mix nodes, something like this:

enter image description here

$\endgroup$
  • $\begingroup$ My glass disappeas with those same settings... $\endgroup$ – Marc Apr 16 '16 at 23:44
  • $\begingroup$ Plus with your screen capture it seems to lose the reflection of the actual light source showing on the glass. $\endgroup$ – Marc Apr 16 '16 at 23:51
  • $\begingroup$ @Marc - I've just appended my answer to hopefully help you on this. It's going to be subjective, so play with the values until you are satisfied. $\endgroup$ – Rick Riggs Apr 17 '16 at 0:00
  • $\begingroup$ --Complex! But you nailed it. Now I have to try and understand it. I can't thank you enough. Someone should write a book just on nodes. $\endgroup$ – Marc Apr 17 '16 at 3:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.