5
$\begingroup$

Everytime I am doing one thing another problem comes up, and I have a deadline to follow unless there is a way to create shadows using another software (after effects)? I want to composite this thing in after effects but I cannot do something simple like a shadows pass. I followed the shadows pass tutorials but of course nothing works. Here is my node setup:

as the backdrop shows, there is only black

enter image description here

here are other settings

enter image description here

enter image description here

Is there anything I am doing wrong?

an update to my node setup:

enter image description here

$\endgroup$
  • $\begingroup$ any more answers $\endgroup$ – user2883800 Nov 24 '13 at 13:40
  • $\begingroup$ Related: blender.stackexchange.com/q/3002/599 $\endgroup$ – gandalf3 Nov 24 '13 at 19:08
  • $\begingroup$ Note that if all you want is a shadow pass that includes everything in the scene, you don't need a second renderlayer. You can just enable the shadow pass on the character layer. $\endgroup$ – gandalf3 Nov 24 '13 at 19:17
  • $\begingroup$ I tried that and nothing worked. Maybe I should continue this without shadow. But it will look weird. $\endgroup$ – user2883800 Nov 25 '13 at 0:20
  • $\begingroup$ Hmm. What precisely didn't work? Could you upload your .blend? $\endgroup$ – gandalf3 Nov 25 '13 at 0:45
5
$\begingroup$

Here is a simple example for using Shadow pass in your case:

enter image description here

I personally prefer combining shadow with other passes like AO, for better result.

| improve this answer | |
$\endgroup$
  • $\begingroup$ it still didn't work. I see the background but not the character and the shadow. $\endgroup$ – user2883800 Nov 24 '13 at 23:45
  • $\begingroup$ @user2883800 Would you like to share with the .blend file? You needn't pack all source data, but should be with same settings. $\endgroup$ – Leon Cheung Nov 25 '13 at 3:05
  • $\begingroup$ it worked. I needed to ad an extra node that was used in another tutorial. I just placed it on there randomly and the shadow appeared. thank you. $\endgroup$ – user2883800 Nov 25 '13 at 4:01
  • 3
    $\begingroup$ Please help future users by telling us what node you added and where you put it. (If you just randomly put it somewhere and it worked, then it was probably a viewer node, which is not required for the final compositing). $\endgroup$ – Matt Nov 26 '13 at 22:57
  • $\begingroup$ I used the image scale node and connected to the image node. $\endgroup$ – user2883800 Nov 30 '13 at 16:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.