0
$\begingroup$

I've tried out Blender 2.77 on my MacBookPro 13" screen and all works as expected. I moved on to my Asus laptop with 15" screen (with a better video display) and installed 2.77 also with the Bsurface add-on.

When holding down the D key to draw with the mouse, nothing is drawn.

Do you have any suggestions? I'm relative new to Blender. Thanks

I've done further testing and here's the issue: One of my PC computers doesn't change the curser to a brush icon when holding down the "d" key. (works fine on another PC - desktop instead of laptop, same manufacture: Asus.)

When I remote into the Mac where Blender functions as expected, drawing is still not working, yet when I remote into the PC from the Mac, the drawing works as the curser changes to a brush. I've contacted the PC manufacturer but they claim it's a software issue but they have offered to have the PC reimaged, something I already did and I have the same issue.

This undocumented feature is unique because drawing works when I use the GreasePencil draw button, but doesn't work when holding "d", and only on this PC laptop, works fine on 2 PC desktops and Mac laptop, one uses Windows 10 as the laptop that has this issue, the other Windows 7. I've tried different versions of Blender still same issue. It would be nice to have a solution or even a workaround because currently this is just an inconvenience in having to take the extra steps to draw lines in Blender.

Anyone else with a suggestion would be appreciated.

$\endgroup$
  • 3
    $\begingroup$ The D key enables drawing with Grease Pencil. Bsurface has nothing to do with that if nothing is drawn. Make sure there's GP layer assigned to the object; also enable it with Draw button in the Toolshelf > Grease Pencil to check you indeed started drawing. $\endgroup$ – Mr Zak Apr 15 '16 at 10:05
  • $\begingroup$ Mr Zak, thank you for your info. I've checked the settings several times again to make sure that drawn lines are set to link to the object instead of scene in both the GreasePencil Toolshelf shelf and the menu for creating a new GreasePencil entry plus created a new layer to confirm detail settings but I still have the same issue. I've added more information describing my further tests to get this resolved, to my original post. $\endgroup$ – Neoicon Apr 17 '16 at 19:53
  • $\begingroup$ Did you try actually drawing with GP on the problem laptop ? It could be that cursor isn't changing to brush but still the tool can work. Anyway this reminds a bug; check that D button really works on that computer, try setting on another shortcut in user prefs. I'd suggest using Continous Drawing option of GP but if drawing for Bsurface then it's not solution. $\endgroup$ – Mr Zak Apr 18 '16 at 9:06
  • $\begingroup$ GP works fine on the GP menu using Draw, the only thing that doesn't work is using the D key on the problem laptop. I can draw using the D key when I remote into the problem laptop from my MacBookPro. If I change that around then the drawing with D key doesn't work from problem laptop to MacBook. The D key does work in other programs with problem laptop. This doesn't appear to be a software issue per my test in exchanging the input via the remote access of the PC and Mac computer, yet how could it be a hardware issue if the PC works with every other program. $\endgroup$ – Neoicon Apr 19 '16 at 9:54
1
$\begingroup$

I found a work around for the issue with the NX500 Zenbook from Asus not working properly with Blender when using the "d" key to draw with the touch pad. It works by just using the touch screen.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.