0
$\begingroup$

I am using Blender v2.74.

The situation

I am working with two .blend files. The main assembly .blend and a separate subassemblies .blend file. As it turns out, the two files are at two different scales. The subassemblies .blend is at 1/10 that of the main assembly file. I linked a subassembly of parths from the subassemblies file. In order to translate, rotate and scale the subassembly, I converted the links to proxies. When I do this, the edge-split modifier on the proxied parts loses its effect, and the smoothing result is not acceptable.

What I've tried

Since all the parts in the subassembly are children of on of the parts there-within, and since I was able to effectively convert its link to a proxy (with the disastrous effects) and have all its children follow the translation, rotation, scale I provided this parent, it made sense that if I were to make this parent part a child to an empty in the subassemblies file, I should be able to convert the link to it in the main assembly file to a proxy, and use it to translate, rotate and scale its children.

When I tried that, it enables me to translate, rotate, and scale the empty, but when I do, none of it's children respond appropriately as they did when their parent object (not the empty) is converted to a proxy and translated, rotated or scales.

The meat and potatoes of the question(s)

  1. Why is this happening? Why is it that when I convert a link to a proxy, it seems to ignore its edge-split modifier, even though the modifier remains in the stack?
  2. Why wont the parents follow their empty parent? Why does a relationship to a physical object allow for children following the translation, rotation and scale of their parent, whereas; one to an empty does not?
  3. How do I get to work? How do I either re-enforce the edge-split modifier on the proxy, or re-enforce the relationship between the parent empty and the child objects?

Going forward

In the meantime, I'll keep playing and hopefully solve my problem. If I do, I shall, of course, post it here.

Yes, I know

In anticipation of some comments or answers suggesting I simply change the scale of either file: I have thought of that, and while it would solve the scaling issue, it does nothing to resolve the translation and rotation issue coupled with the ghastly lack of proper edge-splitting.

$\endgroup$
0
$\begingroup$

As Promised

Like I said in my original post, I would keep playing and post here should I find a solution to the problem at hand.

Questions Answered

  1. Still not clear why it was hapenning.
  2. Not sure why the children would refuse to follow their empty parents.
  3. I was able to get this to work the way I wanted by opening the subassembly's .blend file, and adding all the parts into a group and gave the group a name. Next, in the main assembly's .blend file, I simply linked the group, and only the group, from the subassembly's file. This brought in the subassembly with a lovely gimble for selecting the group. I was able to successfully translate, rotate, and scale the subassembly by use of this gimble. Worked perfectly, and all parts maintained their edge-split modifiers!

Any further details?

It seemed I have answered only one of three of my questions, but in all fairness, this was the most important of the three, since it enabled me to achieve my final goal. Feel free to comment if you know the answers to the other two questions as I am still quite curious as to why it did not work correctly using my original method.

Final Thought

I sure hope someone out there finds this question and answer to be useful in combating any headaches they may experience such as the one I originally had.

Peace and all Good,
Sirach

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.