2
$\begingroup$

I'm trying to setup my blueprints in Blender, and I've more or less achieved it, but the image empties are not displaying the pictures well.

Edit: I think this picture more clearly describes my problem enter image description here

What is going on with the rendering?? It's like impossible architecture.

$\endgroup$
  • $\begingroup$ Can you add a picture of the front ortho? What exactly are you after? It looks like you have both empties' transparency enabled, that will make one empty always show through, depending on the selection. $\endgroup$ – 360ueck Apr 14 '16 at 14:56
  • $\begingroup$ In my opinion, For those kind of blueprints, images as background would work better $\endgroup$ – user1853 Apr 14 '16 at 15:53
  • $\begingroup$ related: blender.stackexchange.com/questions/45471/… $\endgroup$ – user1853 Apr 14 '16 at 15:55
  • 4
    $\begingroup$ If your image does have an alpha channel, make sure it is enabled: i.stack.imgur.com/QU0k3.gif $\endgroup$ – user1853 Apr 14 '16 at 16:02
  • 1
    $\begingroup$ Try change the OpenGL clip-alpha user preference. $\endgroup$ – ideasman42 Apr 15 '16 at 11:09
3
$\begingroup$

With no transparency level set, and all transparency options enabled (for all objects), blender defaults to complete transparency of all objects except the one selected, and behaves similar to x-ray.

To achieve the kind of transparency you'd like, follow these 2 steps:

1) Set a transparency level in properties> data (here I've set both images to 0.35).

Image 1

2) Enable transparency in properties> object.

Image 2

|improve this answer|||||
$\endgroup$
  • $\begingroup$ Playing with the Transparency option, I've found it works exactly like X-Ray: The object that has transparency checked in the objects property panel will always show. I've found that disabling transparency for the top and side blueprints, and enabling it for the front works best, but I still cannot get blender to display the rear blueprint when I am viewing the model from the rear. It always displays the front blueprint, even when I disable transparency for everything and have nothing selected. $\endgroup$ – Mentlegen Apr 16 '16 at 3:53
  • $\begingroup$ @PythonNewbie Did you try setting transparency to 0.34 (for every object) in data? (Step 1). If you don't, one object will always act as x-ray, since the default transparency value is 1 (opaque). The reason your work around is working is because when you enable transparency without setting a value, you are essentially making the object opaque. Which is fine, but when transparency is enabled on at least one other object, it behaves as x-ray (not transparency). I'm sure the physics is relatively correct, but it's not what your looking for; which is why your having to work around it. $\endgroup$ – 360ueck Apr 16 '16 at 4:27
  • $\begingroup$ Yes I did, and it's still showing only one image both front and back view. I guess this is just a limitation of Blender's, although I have NO IDEA why it happens. 3DS Max was so much easier =P $\endgroup$ – Mentlegen Apr 16 '16 at 12:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.