0
$\begingroup$

This is not a repeat of these questions:

No file output after rendering?

How to render an animation as video in Blender?

Blender not rendering animation?

How can I make my Blender animation into a video?

As none of the solutions have helped.

I've been able to render 2 simple animations (in blender render) before without any problems. I made an animation (this time in cycles though) and changed the output folder paths, both in settings>file and properties> render. But there is no new file in the output directory. I can't figure out what I could have done between my last rendering and now to cause this problem.

  • I've tried with multiple image types (i.e: png, jpeg, jpegavi, etc.) but it makes no difference.

  • I'm able to save a single image manually from the UV/Image editor (to the output path selected), but it makes no difference when I actually try to render the animation

  • Running bpy.ops.render.render(write_still=True) in the Python Console doesn't render the animation to the output path selected.

  • Changing the device from "CPU" to "CPU Compute" doesn't help.

  • Blender is calculating something, as every time I hit render, I'm notified when the calculation is finished (takes different amounts of time depending on the image output i've selected).

  • I've tried loading "factory settings" and making a simple animation in there, but it still doesn't render to the folder I've selected.

  • I have both render output paths (in settings>file and properties> render) set to the same folder.

Not even other forms like this one help:

https://www.blender.org/forum/viewtopic.php?t=19567

These pictures are from the simple animation I made using default factory settings:

enter image description here

enter image description here

enter image description here

$\endgroup$
  • 1
    $\begingroup$ can you add images of your current setup? Please include images of your scene that show lights, camera, modifiers, particles, physics or any specific setting you are using. $\endgroup$ – cegaton Apr 14 '16 at 0:30
  • $\begingroup$ Are you stating that no file gets created? The image created is not what you expected? or Something Else? $\endgroup$ – atomicbezierslinger Apr 14 '16 at 0:34
  • $\begingroup$ There is no file created at all. I've added some pictures. In this .blend file, there is only one light and one camera, no modifiers, particles, physics or special settings. The file I first tried to render had a few modifiers, more lights, and 2 cameras. But I thought using the simplest example would help narrow down the problem. I feel it's something to do with my settings and not necessarily the file attributes, since I can't render even a simple animation made from the "factory settings" file. $\endgroup$ – Metamorph Apr 14 '16 at 9:40
  • $\begingroup$ Like it's already advised, open Blender's console (in the top left corner of default window) and set rendering anmation once more. It should write what happens. $\endgroup$ – Mr Zak Apr 14 '16 at 10:20
  • 2
    $\begingroup$ @user321141 don't delete your question! If you resolved your issue please write an answer. I'm sure someone having the same issue will find it useful. $\endgroup$ – cegaton Apr 14 '16 at 15:26
0
$\begingroup$

My renders were not appearing in the output folder as my macintosh was not linked to an icloud account.

Between my successful and failed renders (about 2 weeks) I had deleted my icloud account and created a new one. I periodically received notifications asking me to sign into an icloud account, but since I don't use icloud, I ignored them. Frustrated, I began running virus checks, reinstalled blender and restarting my computer, but it made no difference. Finally, in an attempt to have everything run smoothly, I signed into icloud (after being asked once again).

In lay terms, it seemed apple wanted to be happy before it would let a nonnative program follow the right paths.

After signing into icloud, my renders appeared on the output folder. Hope this helps anyone else experiencing a similar problem.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.