1
$\begingroup$

I do have a new computer (much better than the previous one) and the preview rendering in cycles render is for taking REALLY long time, 5 samples/sec.

I do have Intel i7, 16gb RAM, MSI gtx 970 (4gb), so no idea why it takes so long time.

Any help? Tried changing to CUDA, changed both in user preferences and in the "render" tab. enter image description here

$\endgroup$
2
  • $\begingroup$ Go to blenchmark.com and test your system. Compare that to other GTX 970 machines to make sure you know what "reasonable" is for your setup. Also post here what your time is, so that we have some more diagnostic data. $\endgroup$
    – Matt
    May 13, 2016 at 18:51
  • $\begingroup$ If you can upload your blender file, that might also be helpful. $\endgroup$
    – Matt
    May 13, 2016 at 18:51

2 Answers 2

2
$\begingroup$

When you switch to GPU rendering you need to adjust the render tile size. CPU requires small tile sizes, GPU works better with large ones. Start with a size like 128x128 or 265x256 and see if that makes it better. Make a few test to find an optimal setting for your system

$\endgroup$
6
  • 1
    $\begingroup$ where do I change that? $\endgroup$
    – Omnitored
    Apr 13, 2016 at 17:07
  • $\begingroup$ In the performance section i.stack.imgur.com/88Py1.jpg $\endgroup$
    – user1853
    Apr 13, 2016 at 17:11
  • $\begingroup$ Yes, but I mean during the preview render $\endgroup$
    – Omnitored
    Apr 13, 2016 at 17:12
  • 3
    $\begingroup$ Sorry, I'm terrible at guessing. Please edit your question and ask what you really mean... $\endgroup$
    – user1853
    Apr 13, 2016 at 17:14
  • $\begingroup$ Can you add some screen shots of your render panels settings? $\endgroup$
    – Georges D
    Apr 14, 2016 at 9:14
0
$\begingroup$

You have to enable GPU compute in two places:

User Preferences (Which I think you've already done:

File->User Preferences->System

And the render panel:

enter image description here

I'm running a GTX970 and enjoying the performance. On a simple scene it zips through all 32 samples in the preview in about a second.

-- edit ---

Just say that you mentioned you'd enabled it in both places. I'll leave this post here in case someone else comes along.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .