3
$\begingroup$

So I'm video editting and I keyframe a translation of an image. The property value turns yellow, showing that that frame is the keyframe for that certain value. However, when I go to any other frame and try to keyframe to a different value, the property value is green and I am not able to change the value at all. Whenever I attempt to change it, the value reverts back to the keyframed value. I don't know what to do or how to revert this issue. This happened randomly. Deleted and re adding the image doesn't help and this is happening to anything that I try to keyframe.

I've tried to insert new keyframes and clear the keyframes, but those aren't working... the problem keeps on happening as soon as I add the keyframe...

The issue is similar to the one posted here, except there is no solution to the issue that has worked:

What does it mean when a property is highlighted in green?

$\endgroup$
8
  • $\begingroup$ Please help, Idk why adding a keyframe suddenly locks the whole item in place... I can't animate anything in the project anymore... $\endgroup$ Apr 12 '16 at 6:50
  • $\begingroup$ Works fine for me in 2.77. There used to be a bug involving keyframe in the VSE which sounds similar.. What version of blender are you using? $\endgroup$
    – gandalf3
    Apr 12 '16 at 6:59
  • $\begingroup$ Using 2.76b, but just updated to 2.77, the problem is still there $\endgroup$ Apr 12 '16 at 7:14
  • $\begingroup$ Hm.. I don't see the bug in the todo list anymore, but perhaps it hasn't been fixed yet. Do any of the workarounds stated here help (e.g. closing the preview)? $\endgroup$
    – gandalf3
    Apr 12 '16 at 7:47
  • 1
    $\begingroup$ @gandalf3 the Todo from 2012-10-16 is still there: "Preview rendering resets animated properties when manually editing T32890". Though its description is somewhat confusing... But Sergej mentioned: Workaround could be to close preview when animation or using auto-keyframing. $\endgroup$
    – Samoth
    Apr 12 '16 at 9:14
0
$\begingroup$

The keyframe fixes the property (in this case the position) not only for a certain frame but also influences the future ans past values of that property. By adding only one keyframe that value is fixed for all time on that property. (think of this as a piecewise defined function).

Your solution should be to add a new keyframe i on the frame you want to change the position. This should turn the property field yellow and you can set a new value for that frame. In the sidebar you can change the transition from one value to another over time.

No keyframe: the values are grey enter image description here

keyframe on current frame (frame 0), values are yellow enter image description here frame 12 without keyframe, but a keyframe at frame 0 value is green (and cannot be permanently changed) enter image description here changed value and added new keyframe at frame 12. Values are yellow enter image description here frame 6 without keyframe, between frame 0 and 12, value is green and interpolated between these frames enter image description here

Tldr: to have multiple values over time for one property you need multiple keyframes.

$\endgroup$
7
  • $\begingroup$ The problem is that I cannot add additional keyframes after adding the first keyframe. After I add the first keyframe, all other values of the image become green colored and whenever I try to change the value and keyframe it, the values just revert back to the originally keyframed value. So to summarize, I can keyframe an image once, but then it won't allow me to change any of the values to keyframe additional times. The value bar turns green. Usually, the value bar stays gray. $\endgroup$ Apr 12 '16 at 7:07
  • $\begingroup$ I edited my answer so you can pinpoint what process does not work $\endgroup$ Apr 12 '16 at 7:26
  • $\begingroup$ If it matters, I'm actually using video editing for an image transformation. The thing is, when I try to change the value, like changing x: 0.00 to x:1.00, the value reverts itself back to x:0.00 immediately after i take my mouse off of the value. I can't add a second keyframe unless it is the exact keyframe of the first value, and even then, I can't change the values at all. The values revert themselves back to the original keyframed values. Maybe would sending the file over help pinpoint the problem? $\endgroup$ Apr 12 '16 at 7:29
  • $\begingroup$ I use the "Image offset" property in the "strip input subpannel". I keyframe x: 0 at frame 0, I move to frame 10, the value is 0 and has a green background, i type in another value (e.g. x: 10). The value stays unless I press "left","right" or something else to move to another frame (then it reverts to the first value). Above the changed value I press "i" to insert a new keyframe. No I have a keyframe at frame 0 with x:0 and at frame 10 with x: 10. Which of these steps does not work for you? $\endgroup$ Apr 12 '16 at 7:45
  • $\begingroup$ when I type in the other value. Like when I type in x:10 , the value immediately reverts back to x:0 $\endgroup$ Apr 12 '16 at 7:48

Not the answer you're looking for? Browse other questions tagged or ask your own question.