2
$\begingroup$

I'm using Blender 2.77 on Linux. Today I must have pressed something - I don't know what - and the camera started to behave strange.

When I press NUM 0, the view goes to Camera Persp, but I don't get the usual layout (darkened border when just looking from camera perspective and red border when using Lock to View), like this:

enter image description here

This is certainly something local to the file I'm working on, because when I started Blender again and went to the starting scene, the camera works correctly (as you can see in the screenshot above). This does not happen with my other work file.

Also, when I select Lock to View in the N panel, I still can't change the view and every test render appears the same because of it.

I searched through all the camera options, probably clicked everything, but I still didn't fix it. I searched here and generally on Google, but there was no answer. I don't even know the name of the option responsible for this behavior, so I can't search efficiently for it.

How to revert my camera to the default behavior?

$\endgroup$
  • 3
    $\begingroup$ maybe related blender.stackexchange.com/q/6341/19287 , blender.stackexchange.com/q/2014/19287 $\endgroup$ – Dan Apr 11 '16 at 10:05
  • 1
    $\begingroup$ @Dan I'm not sure it's the same thing, but solution from blender.stackexchange.com/a/26211/23110 did solve the problem. $\endgroup$ – Paweł Pela Apr 11 '16 at 10:27
  • $\begingroup$ @MrZak I didn't provide a screenshot because the situation looked just like any other view - there was nothing special that appeared or changed. The only difference was that it said Camera Persp in the top left corner of the 3D view. $\endgroup$ – Paweł Pela Apr 11 '16 at 10:28
  • $\begingroup$ If you meant that red outline in Camera View like on your screenshot, then that one isn't there by default, it's Render Border used which is drawn by Ctrl+B. Camera Persp will be in the top left corner by default if you enter Camera view. $\endgroup$ – Mr Zak Apr 11 '16 at 10:34
  • $\begingroup$ Couldn't you just zoom in camera view, so the borders are outside the 3D view window, and then turn on the Lock to view? $\endgroup$ – Monkok Apr 11 '16 at 18:56

Browse other questions tagged or ask your own question.