0
$\begingroup$

I studied about the topic of shadows in blender and found this page from the manual. It states that blender needs to be in GLSL mode for this option to be available. How do I add shadows to material properties?

cycles material nodes

That is the material I want to add shadows too.

$\endgroup$
1
$\begingroup$

Those settings are for either Blender Internal rendering engine, or for the Blender Game Engine, displaying shadows in the viewport for Blender Cycles materials and shader is not currently supported.

Either switch rendering engines (on the pulldown menu that reads Cyckes Render in the header of the Info Window on the top blender screen) and rebuild your materials for the new render, if your priority is getting viewport shadows; or if you wish to remain with Cycles then use viewport rendered preview (Shift + Z)

Edit: To achieve a shadowless material setup in cycles you can use a light path node to drive a mix shader between a glass and a transparent shader as illustrated bellow.

Shadowless Cycles Material

$\endgroup$
  • $\begingroup$ See this scene i.stack.imgur.com/0WHPN.jpg , my priority is to remove shadows of water drops in this render without changing my renderer an tricks to do that in cycles? $\endgroup$ – Psytrancemute Apr 9 '16 at 17:15
  • 1
    $\begingroup$ You can use a light path node for that, check the updated answer above. $\endgroup$ – Duarte Farrajota Ramos Apr 9 '16 at 17:34
  • 1
    $\begingroup$ another way is to go under object data ->cycles settings >ray visibility and uncheck shadows for the can material it works same as receive transparent option in game engine and blender render $\endgroup$ – Psytrancemute Apr 10 '16 at 6:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.