4
$\begingroup$

I'm having some trouble while trying to render a scene; what happens is, when I render it in Cycles, everything in the picture is orange instead of its material. When I render it in Blender Render nothing shows up at all except for the sky background.

Orange room in Cycles:
rendered in cycles

When rendered in Internal Render:
rendered in Blender Internal Render

Living room.blend

$\endgroup$
4
  • $\begingroup$ It looks to me like your lighting is giving the orange color to your cycles render. $\endgroup$
    – David
    Apr 7 '16 at 22:37
  • $\begingroup$ @cegaton I'm making a scene of a living room, there are various materials throughout and I added them through the Cycles Render materials area. the lighting is through a sun lamp and it is placed right outside the window. Because i am so new to blender i used mainly simple shapes to create the furniture and the room. $\endgroup$ Apr 7 '16 at 22:50
  • $\begingroup$ @David I thought that at first too, but no matter what type of lighting I use it doesn't change the type of coloring you see in the picture $\endgroup$ Apr 7 '16 at 22:51
  • $\begingroup$ It seems you have an official answer below. Please mark the answer as accepted if you agree. $\endgroup$ Apr 8 '16 at 0:21
9
$\begingroup$

You will laugh when you see how simple this is.

You have the material for your table leg set as the render layer material override. What that does is override all your materials with that one (and because only the books have a UV map you don't see that texture expect on the books.)

Simply clear the Material Override, switch back to cycles and it will render normally. (All your materials are for cycles, so none of them will work in the internal render.)

Material Override button in the render layer settings

EDIT:

Newer versions of blender don't use layers, but "collections" so the override function is in the scene>View Layer section.

enter image description here

Additional info:

Where is the Layers panel in Blender 2.8?

2.8 - Is it possible to assign (override) a material to a whole collection?

$\endgroup$
2
  • $\begingroup$ glad to help! PS you will need to UV unwrap the floor and table legs, or use generated coordinates $\endgroup$
    – David
    Apr 7 '16 at 23:41
  • $\begingroup$ Though Davids answer is a bit more detailled, you should consider UV Georges' answer down below as well as he actually did give the right answer just two minutes earlier ;-) $\endgroup$
    – Samoth
    Apr 11 '16 at 20:54
1
$\begingroup$

It happened to me once, turned out to be that I accidentally assigned a material to the Render Layer, Go to the Render Layer and check it out, if there's an assigned material, remove it by clicking the X button next to it.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.