0
$\begingroup$

This is my model. I'm trying to create a skyscraper

enter image description here

Now in edit mode is this one:

enter image description here

As you can see the many polygons creating my model are also into the skyscraper, i.e. they don't finish on the surface of my model but they continue inside it. This is because i create many polygons that i combine each other to create a bigger model. In the end i simply unified all meshes in one with CTRL + J. Then inside my model there are vertices, faces and edges.

The problem is this one: i have tried to export my model in fbx and this is the result:

enter image description here

Why I can't export in fbx my model?

EDIT FILE BLEND

$\endgroup$
2
  • 2
    $\begingroup$ It seems this thread faces exact your issue and the fix is nearly the same except for actions needed - just renaming isn't enough. The UV map of your object is really weird and I don't think it gives expected results; redo it with any other way or delete it.. $\endgroup$
    – Mr Zak
    Apr 6 '16 at 20:42
  • $\begingroup$ ok thank you it works!! Do you think there is a way to delete all the edges and the faces and vertices inside my mesh(i.e. that i can't see) in order to optimize my mesh? $\endgroup$
    – Fuboski
    Apr 6 '16 at 21:01
3
$\begingroup$

You may want to reconsider your modeling method as it produces lots of unnecessary geometry, face intersections, and fragmented mesh with no flow.

There is no easy one-button press to clean it up quickly, but you could try the new Edit Mode Boolean operations in Blender 2.77.

By selecting one of your "shards" (a complete chunk of connected faces or geometry) and pressing Space bar and Searching for Intersect or Boolean you could let blender try and detect all intersections and cut geometry accordingly. You can then easily erase all surplus geometry by hand and repeat operation for all remaining independent chunks.

$\endgroup$
6
  • $\begingroup$ Than you so much!!! Didn't know this new feature. Tomorrow i wil try this option and i'll write you here :) $\endgroup$
    – Fuboski
    Apr 6 '16 at 23:48
  • $\begingroup$ it doesn't work as i want; the tool cancels the area outside my meh not the one inside $\endgroup$
    – Fuboski
    Apr 7 '16 at 15:47
  • $\begingroup$ Maybe try to invert the normals with Ctrl+N in edit mode, see of that works $\endgroup$ Apr 7 '16 at 17:30
  • $\begingroup$ i have already tried :/ $\endgroup$
    – Fuboski
    Apr 7 '16 at 17:32
  • 1
    $\begingroup$ Well then I am out of suggestions, maybe someone more experienced has a better ideas. Otherwise I would strongly suggest trying a cleaner modeling practice with extrusions and single surface operations, or using different objects for each "chunk of building", that way you can use the Boolean modifier in object mode. You could try and separate your currfen mesh with P > "Loose parts" and then try to use the Boolean modifier, although that will only work for closed watertight meshes. $\endgroup$ Apr 7 '16 at 17:39
0
$\begingroup$

I know I am really late, but I had this problem too and fixed it.

  • Go to edit mode, select all of your mesh by pressing A

  • Hit F3 (Blender 2.8+) and then search for and apply:
    Merge by distance
    Delete Loose
    Fill Holes

All of these can be found under Mesh>Clean up in Edit Mode.

After doing this I was able to export as FBX without any problems, and nothing messed up with the mesh as well.

$\endgroup$
0
$\begingroup$

In my case, there was something wrong with uv map, after unwraping it with Smart UV Project I could export to fbx BUT then there was something wrong with fbx itself. After unlinking all materials from object in outliner I was able to export valid fbx file.

$\endgroup$
1
  • $\begingroup$ Please add further details to expand on your answer, such as working code or documentation citations. $\endgroup$
    – Community Bot
    Sep 2 at 13:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.