0
$\begingroup$

I am trying to import a .SVG curve and use it to cut shapes into a robot's mesh that I am modeling.

After importing the curve and following Thom Blair III's advice from this question, the result when I click is that nothing happens. It worked with the same curve on the same mesh a little above than where I'm trying, but not on the lover part.

enter image description here

What can cause knife project not to work in some cases? Is it because I imported the curve? If so, why did the curve work on other parts of the same object?

Here's the blend file:

$\endgroup$
  • 1
    $\begingroup$ Well up until now I didn't even know you could knife project from a curve, which is quite awesome, thanks for that! Other than that, the knife project operation is view based, so it depends on your current viewing direction. You should probably be aligning your view orthographically with the mesh if you ever want any sort of geometric accuracy. Also check if you face normals are are pointing outwards and try checking the option Cut Through to see if it helps. Otherwise try separating the desired part of the mesh temporarily into another object, cutting and the rejoining. $\endgroup$ – Duarte Farrajota Ramos Apr 6 '16 at 4:04
  • $\begingroup$ Hi Duarte, did you try to knife project from a curve since this question was posted? I can't see the shadow of an answer yet, but would love to share experiences with other users where this works or doesn't... and why heheh... $\endgroup$ – MicroMachine May 13 '16 at 23:31
  • $\begingroup$ I just downloaded your blend file and I have been knife projecting like crazy to see where it fails and have come empty handed. Even at grazing angles, inverted normals, from inside or outside the object, even through other objects in the way, cutting never failed. I have no clue what it might be. Are you sure the command is registering? From closer inspection to your screenshot I see no "Knife Project" panel pop up in the tool shelf after you press the button, there should always be an operator panel with tool options there after executing an operator. $\endgroup$ – Duarte Farrajota Ramos May 13 '16 at 23:53
  • $\begingroup$ Yes, the screen grab is rather crappy, I will try to redo it. Was the .svg shape imported inside the blend file or did you try from one of your svg curves? (I'm not near my 3d computer right now). Thanks $\endgroup$ – MicroMachine May 14 '16 at 0:08
  • $\begingroup$ Yes, U used that same exact rounded square in your screenshot and it worked well every time, not sure why it's failing for you. What version of Blender are you using? Have you tried restarting Blender when it fails? It may well be a bug causing trouble. $\endgroup$ – Duarte Farrajota Ramos May 14 '16 at 2:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.