I recently bought a new configuration to increase rendering performance with Cycles. It's an Intel Xeon E5-2620V3 6 core 2.40 GHz with 32GB of DDR4 ram. Video card is Nvidia Quadro M4000 8GB GDDR5. I assumed that GPU rendering should be faster than CPU rendering on this machine, but the opposite is true. For a rather simple scene (1000 samples), CPU rendering took about 18 minutes whereas rendering it with GPU took one hour and 23 minutes ... (which is even way slower than when rendering it with GPU on a lower performance computer). Blender does recognise the card (it shows up in the system settings) but does not really seems to use it, I guess. Anyone any idea what I might be doing wrong here or why the GPU rendering is so slow? thanks, Dominique Adriaens

  • Though Blender isn't optimized to use the extra features of the Quadro cards, something does seem off here. (I have a Quadro M4000 and I can't imagine a processor, even a Zeon being that much faster.) – PGmath Apr 4 '16 at 13:14
  • Your M4000 should render in approx 10% less time as GTX 970. Look up some render times of BMW scene and compare. If your's are off I would check and suspect drivers first. – Jaroslav Jerryno Novotny Apr 4 '16 at 17:17
  • Thanks for the suggestions! Changing tile size to 256x256 and switching off auto-size add-on did the trick. – Evomorph Apr 5 '16 at 12:16

Both your CPU and your GPU are quite good. Have a look at blenchmark. Your CPU is right up there and comparable to good GPUs. So it's not to be expected that the difference in render times will be huge. However, to optimise render times for CPU/GPU you should use the auto-tile add-on from user preferences. Just activate this addon and render times will be optimised.

  • we usually set the tile size to 256x256 pixels for gpu. this is really an important thing to consider. (yes you can also use an add-on but if you quickly want to check if this will improve your performance...) render tab > performance > tile size are you setting the device to GPU compute? – Madlaina Kalunder Apr 4 '16 at 13:10
  • Thanks for the suggestions! Currently, tile size is set to 250x250, but it does not accept changes if I try to set it to 256x256 on that computer. On another computer, tile size is set to 256x240, and also there I cannot change that. Is there another setting I need to change first? – Evomorph Apr 5 '16 at 11:46
  • OK, found that I had the auto-tile add-on selected, which explains why I could not change the tile size. So, switched off the auto-tile add-on and changed size to 256x256 and bam ... render time reduced to 4 mins and 148/ seconds for that model! Thanks a thousand for the suggestion! – Evomorph Apr 5 '16 at 12:15

Are you adjusting the tile size when you switch form CPU to GPU?

GPUs work better with larger tiles. make a test at 256x256.

CPU on the other hand will work better with smaller tiles (64 or 128, or even smaller).

Another thing to consider is that if you only have one GPU, you are using resources not only for rendering, but for everything else displayed on the screen, which might also affect performance.

Lastly, with a singe GPU you are rendering one tile at the time, vs 6 (or more depending on multithreading) on CPU rendering

  • Make a few tests and find the optimal tile size for your system. It's different for different systems. – cegaton Apr 5 '16 at 14:23
  • Will do, thanks for the suggestion! – Evomorph Apr 6 '16 at 20:23

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.