2
$\begingroup$

I'm making a model for a voxel style game. I've modeled it in Qubicle and exported it to Blender for the animations. But in my mesh most of the faces or edges are not connected, and I can't find a way for doing it so. That is affecting the mesh light in Unity.

Unlinked Edges

I've tried with the simple Ctrl while dragging, but that does not connect it. I've also tried putting new vertices and merging both. But the mesh and the UV maps (directly imported from Qubicle) keeps distorting.

Merge Error

I don't understand why it's so hard in a so basic mesh. Is there a simple way to do it. I'm desperate, please help!

$\endgroup$
  • $\begingroup$ If there are edges of the mesh and they simply aren't connected to each other use W > Remove Doubles to remove double vertices; you may want to change Threshold value in operator settings. $\endgroup$ – Mr Zak Apr 1 '16 at 22:14
1
$\begingroup$

You need to use Remove Doubles.
In Edit Mode, press A once or twice to select all vertices, then Ctrl + V and choose Remove Doubles, this will weld all vertices sharing same location.

$\endgroup$
  • $\begingroup$ And to add to that, when @Georges says "same location" it means exactly the same location, so if they are even a tiny bit off it will not merge. Select the not merging vertices and turn on vertex snap and bring it to where you want, should fix it. $\endgroup$ – Luka ash Apr 2 '16 at 1:00
  • $\begingroup$ @Lukaash in Remove Doubles, a margin can be used for vertices location, I think it might work even if they were a little bit off $\endgroup$ – Georges Apr 2 '16 at 2:09
  • $\begingroup$ Oh wow, didn't know there was such a big allowance of how far away they can be, never the less, when the difference is visible by the eye and and slightly far away and maybe even different z and x, lock to vertex could be helpful, or am i wrong? $\endgroup$ – Luka ash Apr 2 '16 at 9:22
  • 1
    $\begingroup$ @Lukaash you're right, it all depends on the mesh, sometimes you have to do things manually, but in this case the mesh isn't that dense, so I think this might work $\endgroup$ – Georges Apr 2 '16 at 10:54
  • $\begingroup$ Hmm, i suppose i agree. $\endgroup$ – Luka ash Apr 2 '16 at 20:32
1
$\begingroup$

It's not really clear from the images what you want to do, they are a bit confusing, but it seems you are missing some patches of mesh or faces.

Your mesh looks quite messy, as suggested before try first removing doubles with W > Remove Doubles while in edit mode with all vertex selected. You may also be seeing some normal issues, try unifying normals by entering edit mode, selecting all with A and the pressing Ctrl + N to recalculate normals.

After that you can then manually connect any two pieces of geometry with the fill function through the F key. Select two or more edges, press F and it will create a face, select two vertex press F and it will connect them with an edge.

If you have two edge loops with the same ammount of eges you may also use the Bridge operator to connect them with B key.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.