I'm not sure if this is a bug as I can replicate the problem...which is odd because I'm using 2.77 which isn't a beta version as far as I know. I've tried researching but haven't come up with much. It'd be faster to simply remake the mesh, but I'm curious since I can replicate the problem but can't find a similar question.


1- Enabled X-mirror and Topology mirror in Editmode

2- Selected all vertices and pressed "G"

3- Mesh disappears


  • The object origin is still visible in 3D view.

  • The object is still existent in Outliner

  • The object is not hidden in Outliner.

  • "Alt H" does nothing in 3D view (object not hidden by "H")

  • The view is not in local view.

  • “View selected” responds and zooms to object origin dot.


Image 1

IMage 2

  • $\begingroup$ Please add Blender screen capture images to help clarify your question. $\endgroup$ Commented Apr 1, 2016 at 17:31
  • $\begingroup$ What is the vertex count in the Info window in object mode? In edit mode before the attempted grab what is the vertex count? After G, when you press A to [select all] what is the vertex count? 0 zero or non zero 0? Have you deleted all vertices somehow? $\endgroup$ Commented Apr 1, 2016 at 17:34
  • $\begingroup$ cegaton I'm on mac. atomicbezierslinger That was my first thought but vertices all still there. Mentalist I used to watch that show too. It's not a modifier, just a option in toolbox>options. $\endgroup$
    – 360ueck
    Commented Apr 1, 2016 at 19:47
  • $\begingroup$ In the bottom right hand corner, second image: Blender is responding to grab -- it's in translate mode. $\endgroup$
    – 360ueck
    Commented Apr 1, 2016 at 19:55
  • $\begingroup$ HD graphics 5000. I double checked to make sure blender is using it, and it is. I also tried telling blender to just use CPU and problem still exists. $\endgroup$
    – 360ueck
    Commented Apr 1, 2016 at 20:06

1 Answer 1


Your mesh contains a lot of bad data, you should find that this bad data is causing the issues you are having.

With your object in edit mode, change to vertex select mode and de-select all vertices. With the mouse over part of the mesh press L - this will select all vertices linked to what is under the cursor. I see 748 vertices selected by this method.

info bar

I find that doing a select inverse and deleting the unconnected vertices still leaves some bad data. The following script deletes vertices that have one or more location values identified as NaN (Not a Number) which would be the reason you are having issues. After running this script I see 555 remaining vertices and find I can work with the remaining mesh and don't see any visual change.

import bpy, bmesh

obj = bpy.context.object
bm = bmesh.new()
bad_verts = 0

for v in bm.verts:
    if isnan(v.co[0]) or isnan(v.co[1]) or isnan(v.co[2]):
        bad_verts += 1

print('Removed {} bad vertices'.format(bad_verts))

  • $\begingroup$ Thanks, that helps. I sort of had that idea, but thanks for describing it in the right language. After L select>inverse>delete and running the script 46, 209 out of the original 144,440 remain. However that doesn't solve my problem for the mesh that isn't displaying (other object in the file). I ran the script and "Removed 0 bad vertices". Here is the original: <img src="http://blend-exchange.giantcowfilms.com/embedImage.png?bid=1162" /> $\endgroup$
    – 360ueck
    Commented Apr 2, 2016 at 21:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .