2
$\begingroup$

I've encountered a strange problem with the snap during transform setting, where it seems to be being ignored.

I've tried toggling it on/off, using the different snap modes (to vertex, edge, face, etc), snap targets, but the behavior that I previously had (being able to drag a vertex towards another and have it snap) seems to have been lost somehow.

I'm assuming I accidentally hit a key combo that changed something but I'm fairly new to blender so I'm not sure what that would be.

Hitting Ctrl seems to move the vertex some units in a direction, but doesn't actually snap it to the nearby vertex.

Here's a quick image of what I'm experiencing: enter image description here

I should mention that snapping to grid seems to work fine - all other snapping methods do not.

$\endgroup$
  • $\begingroup$ I have never understood the snap system in blender, I use "double g" when i need to slide parts of my mesh. $\endgroup$ – Yvain Apr 1 '16 at 9:02
  • 1
    $\begingroup$ Do you have Snap to itself option activated which is just to the right of snap buttons ? It's not seen on your gif. $\endgroup$ – Mr Zak Apr 1 '16 at 15:05
  • $\begingroup$ @MrZak thx for your comment. Post expanded. $\endgroup$ – Dan Apr 1 '16 at 16:53
  • $\begingroup$ Looks like you have non-manifold geometry which bumps you... $\endgroup$ – Samoth Apr 13 '16 at 16:56
4
$\begingroup$

The reason why it does not seem to work is that the mouse cursor is not hovering exactly over the vertex which is to snap.


  1. Enable Snap during transform by clicking on the red Magnet symbol or by pressing Shift + Tab.
  2. Choose Vertex as Snap Element
  3. Enable Snap onto itself

    enter image description here
    *If Snap during transform is disabled you can hold down Ctrl during Translation (G).*


  • Hover the Mouse cursor over the desired Vertex

    Make sure you hover exactly over the Vertex otherwise it won't snap

    enter image description here
    A little circle will appear on the Vertex


 

Another possibility to achieve the desired result is to Merge the Vertices

  • Select the two Vertice by holding down Shift and click RMB
  • Press W and choose Merge
  • Choose 'Merge at Last' or 'Merge at First' depending on the selection order

    enter image description here

$\endgroup$
  • $\begingroup$ Sadly this didn't seem to be the issue - Reinstalling blender and copying my project into a new fle (within the original file the issue persisted) seemed to get snapping working again, and I haven't run into it since. $\endgroup$ – Lucas Penney Apr 4 '16 at 18:25
  • $\begingroup$ @LucasPenney maybe you want to upload the ~.blend file? $\endgroup$ – Dan Apr 5 '16 at 7:26
2
$\begingroup$

And check Proportional Editing mode is Disabled. Snapping doesnt work with it :) enter image description here

$\endgroup$
1
$\begingroup$

I came here with the same problem and found my solution in the comments so I will add it as an answer.

"Do you have Snap to itself option activated which is just to the right of snap buttons ? It's not seen on your gif. – Mr Zak Apr 1 at 15:05"

I did have Snap to itself deactivated. After activating it snap started working again.

$\endgroup$
1
$\begingroup$

One importante thing about the snap transform. It doesn't work if you display a Subdivision Surface Modifier. Maybe here is the only reason why you encountered this issue.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.